1990 YJ Electrical issues.... - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 09-01-2011, 07:33 AM Thread Starter
jraisor
Registered User
1990 YJ Wrangler 
 
Join Date: Jul 2011
Location: Buffalo
Posts: 5
1990 YJ Electrical issues....

so i recently got my first jeep a few weeks ago. needs some tlc but overall im enjoying it.

SO last night im driving and all of a sudden my headlights, radio, dash lights all brown out and then die few seconds later my jeep dies. Jeep will crank but will not start up. no Dash lights, radio, brake lights etc i could smell something electrical burning but it was pitch black so couldn't see any smoke or tell where it was coming from, had AAA tow it to my house.. i checked the fuses under the dash and they all look in order. checked to make sure my battery cables were tight etc.....

anyone have any suggestions on what to check?

jraisor is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-01-2011, 08:01 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,796
Look at the fuseable links that come off the starter relay on the firewall by the battery. I would also be looking at the battery cables and alternator cables for corrosion.
Que89YJ is offline  
post #3 of 9 Old 09-01-2011, 08:06 AM
woodmanxxx
Registered User
1990 YJ Wrangler 
 
Join Date: Dec 2004
Posts: 74
When you say "cranks" do you mean, it will -just turn over- or do you mean it sounds like it usually does but doesn't fire? That will give everyone a great starting point to trace the problem.

I average 10 posts per year. 7years/70posts.
woodmanxxx is offline  
post #4 of 9 Old 09-06-2011, 02:54 PM Thread Starter
jraisor
Registered User
1990 YJ Wrangler 
 
Join Date: Jul 2011
Location: Buffalo
Posts: 5
Sorry took so long to come back to this, I think it's a bunch of issues that are contributing to this.

Looking at the firewall there is a module with a post that has a bunch of wires running to it that someone spliced together with household twist ons, removed all of that and put proper ring terminal connectors on, next I pulled the ecu behind the glovebox cracked it open and see some burns on some parts of the board, actually looks like a PO had an issues before because I see non factory wires soldered in to create a path where there was a burn mark. Having the ecu worked on by a buddy who works on mother boards and circuit boards. I think I either have a bad ground or a short somewhere.

Does the ecu control spark to the distributor because I did the ol screw driver in the coil cable trick and I'm not getting spark, also got a new coil and that doesn't seem to fix the spark issue.
jraisor is offline  
post #5 of 9 Old 09-06-2011, 03:02 PM Thread Starter
jraisor
Registered User
1990 YJ Wrangler 
 
Join Date: Jul 2011
Location: Buffalo
Posts: 5
Also does anyone have a wiring schematic for the ecu itself, I don't think it's in my Haynes manual
jraisor is offline  
post #6 of 9 Old 09-06-2011, 03:15 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,796
You need to post up the info for the Jeep profile information. It would just be guessing as to what you are talking about.
Que89YJ is offline  
post #7 of 9 Old 09-06-2011, 03:22 PM
goldeaglejeep
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2011
Location: hattiesburg
Posts: 67
Sounds like you need to start with a fresh harness, seems like it wouldn't be worth all the mess you have occurring.
goldeaglejeep is offline  
post #8 of 9 Old 09-06-2011, 03:23 PM Thread Starter
jraisor
Registered User
1990 YJ Wrangler 
 
Join Date: Jul 2011
Location: Buffalo
Posts: 5
What's a fresh harness going to put me back for?
jraisor is offline  
post #9 of 9 Old 09-06-2011, 04:11 PM
goldeaglejeep
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2011
Location: hattiesburg
Posts: 67
Ebay they can be had for 80-150 for the dash harness should be all you need. I would feel much better doing that even if it does cost some money. This sounds like it will just be one problem after another.
goldeaglejeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1990 electrical doozy. keyloki YJ Wrangler Technical Forum 8 11-28-2010 01:45 AM
1990 4.2 weber fuel pressure issues tippmann243 YJ Wrangler Technical Forum 7 05-23-2009 06:07 PM
1990 YJ electrical problems Nutter78 YJ Wrangler Technical Forum 1 05-04-2009 02:30 PM
New problem, still dealing with electrical issues. UPDATED, STILL HAVE ISSUES!!!!! rustywrangler YJ Wrangler Technical Forum 34 02-17-2009 04:51 PM
1990 Wrangler 258 to 4.0 engine swap, any issues? HeepToJeep YJ Wrangler Technical Forum 2 11-26-2008 10:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome