1989 YJ Starting Issue? Electrical? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 08-26-2011, 11:53 AM Thread Starter
yabo71
Registered User
2000 TJ Wrangler 
 
Join Date: Sep 2010
Location: Grand Haven
Posts: 245
1989 YJ Starting Issue? Electrical?

Ok. It a 1989 2.5 5 speed yj. Until last friday it ran fine. I had Tuffy do some welding on the exhaust and every since it will not run. They replaced the computer. Then the fuel pump was not working. I put the new fuel pump in and it now pumps fuel. Only problem it still will not run. As for the electrical now when I touch the brake pedal the hazard lights, radio and gauges go haywire, Also when I turn the headlights on the hazard lights, radio and gauges also go haywire and the headlights them selves do not come on. Any help? Things to check?

yabo71 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-27-2011, 04:24 AM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,687
check all the grounds.. and clean them.

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1989 YJ Islander with 289 conversion electrical issue alpinevend YJ Wrangler Technical Forum 7 08-09-2011 01:59 PM
1989 yj 2.5 starting issue rzrefi09 YJ Wrangler Technical Forum 3 05-03-2011 01:02 PM
starting/electrical issue??? need help twizz TJ Wrangler Technical Forum 1 05-24-2010 05:27 PM
1989 4.2 Starting blue89wrangler YJ Wrangler Technical Forum 18 01-06-2009 10:28 AM
YJ starting issue (perhaps electrical) Inch7706 YJ Wrangler Technical Forum 1 09-06-2008 04:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome