1"bl now 4wd light stuck on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 1"bl now 4wd light stuck on

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 10-17-2011, 06:04 PM   #1
mbaseel
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2011
Location: Portland, OR
Posts: 51
1"bl now 4wd light stuck on

Hey guys so I have been googling and searching forums and cant seem to find anything on what I am looking for... so here is the problem...
I installed a 1" body lift and now my 4wd light is stuck on. This is more annoying than anything cause it goes into 2wd and drives fine but the light stays on. Any suggestions on what may have happened and how to fix this?
thanks for the help,
Mike

mbaseel is offline   Reply With Quote Quick reply to this message
Unread 10-17-2011, 06:45 PM   #2
Louie4
Powah Injanir
 
Louie4's Avatar
1993 YJ Wrangler 
 
Join Date: Aug 2008
Location: Raleigh, NC
Posts: 9,903
My 4WD light was stuck on for about 6 months at one point. I finally got under there and unbolted the CAD cover and cleaned the vacuum shift motor with some brake cleaner. After that it worked fine. That was about 8 years ago.

Another thought is to check all your vacuum lines. You might have pulled something loose when you were doing the body lift.
__________________
Lou

I have a jeep...and it is modified...I win.

YJOTM July 2012
YJOTM February 2014

Louie4's YJ Build
Poison Spyder Fender Install
Warn M8000 Rebuild Adventure
University of Georgia
Louie4 is offline   Reply With Quote Quick reply to this message
Unread 10-19-2011, 08:00 PM   #3
mbaseel
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2011
Location: Portland, OR
Posts: 51
So I got under an checked the vacuum lines and where the 4 lines plug into the transfer case only one has vacuum and only one of the lines has vacuum at the cad. I was able to switch the one that was working over to the spot of the one that wasn't working on the cad and the 4x4 disengaged and it is now in 2wd. I think this is either pointing to a sensor or cracked line. Any other suggestions?
mbaseel is offline   Reply With Quote Quick reply to this message
Unread 10-19-2011, 09:26 PM   #4
Louie4
Powah Injanir
 
Louie4's Avatar
1993 YJ Wrangler 
 
Join Date: Aug 2008
Location: Raleigh, NC
Posts: 9,903
It might be the vacuum switch that the 4 line plug went to. When you shift to 4wd it routes vacuum to the other line on the axle to disengage the CAD system in the front axle. I wouldn't rule out a cracked vacuum line though.
__________________
Lou

I have a jeep...and it is modified...I win.

YJOTM July 2012
YJOTM February 2014

Louie4's YJ Build
Poison Spyder Fender Install
Warn M8000 Rebuild Adventure
University of Georgia
Louie4 is offline   Reply With Quote Quick reply to this message
Reply

Tags
4wd , 4x4 , bl , body lift

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.