XJ is hiccuping and feels like misfiring - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > XJ is hiccuping and feels like misfiring

NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDUSA Standard Chromoly Front Axle Shaft Kits with Dana 30 4Rugged Ridge Modular XHD Snorkel Now for both 3.8L and 3.6

Reply
Unread 04-02-2013, 08:49 AM   #1
jclawson01
Registered User
1996 XJ Cherokee 
 
Join Date: Sep 2011
Location: boise, Idaho
Posts: 27
XJ is hiccuping and feels like misfiring

my cherokee is will randomly hiccup while driving (best description i could think of) it does this very random. Some days it kinda chugs along, but then other days it runs like a top. When I pulled off the highway last week as i slowed down it just died, it didn't lurch or make any sounds the RPMs just went down till it shut off. It fired back up and I drove it just fine.

Last week I took it to lunch stopped at Target and when I came back it wouldn't start. I could hear it turning the engine over but no sputters. I left it came back 4 hours later and it started up just fine.

The spark plugs, wires & cap were replaced about 10,000 miles ago

Any help on this would be great thanks

jclawson01 is offline   Reply With Quote
Unread 04-02-2013, 11:25 AM   #2
Max78
Registered User
1992 XJ Cherokee 
 
Join Date: Jun 2009
Location: Tucson,AZ
Posts: 319
Have you checked fuel pressure, How many miles are on the Jeep? Injectors been cleaned or replaced at all?

I'm dealing with something similar right now, low idle, random sputtering, stalling when stopping. I'm thinking its electrical so I'm replacing cap, rotor, wires, and plugs. If it persists I will do injectors next as they look to be in piss poor condition. . .
__________________
92 Cherokee - All nude and in need of some tlc!
Max78 is offline   Reply With Quote
Unread 04-02-2013, 05:53 PM   #3
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,429
It's possible that this could be the front end of a crankshaft position failure. Not classic symptoms of it, but I've seen them act this way.......

Do you know if this is the original crank sensor?
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline   Reply With Quote
Unread 04-05-2013, 08:14 AM   #4
jclawson01
Registered User
1996 XJ Cherokee 
 
Join Date: Sep 2011
Location: boise, Idaho
Posts: 27
it has 333,000 miles, and I think most of the parts are still orig. I think it was towed behind a motor home for a good part of its life. How do I clean the injectors?
jclawson01 is offline   Reply With Quote
Unread 04-05-2013, 05:51 PM   #5
Rusty Barrels
Registered User
1979 CJ7 
 
Join Date: Dec 2006
Location: KENT
Posts: 17
Change your fuel filter.
Rusty Barrels is offline   Reply With Quote
Unread 04-05-2013, 07:28 PM   #6
Kalali
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2012
Location: Ocean, NJ
Posts: 493
So are you saying the odometer was accumulating the miles while being towed behind the motor home? How many miles on the engine?
Kalali is offline   Reply With Quote
Unread 04-08-2013, 02:37 PM   #7
jclawson01
Registered User
1996 XJ Cherokee 
 
Join Date: Sep 2011
Location: boise, Idaho
Posts: 27
I changed the fuel filter just over a year ago, and I don't know how many miles are on the engine
jclawson01 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.