What is wrong?? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 09-29-2010, 04:16 PM Thread Starter
Cro577
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: Layton, Utah
Posts: 105
What is wrong??

Okay, so I have a 1991 Limited it runs flawlessly, until you look at the speedo, its the only gauge that doesnt work.. But it isnt just a not working deal, sometimes it works, othertimes it doesnt work.. What is wrong with it? is there a way to fix it or do I need to get another cluster?
Also, the Right-rear turn signal has stopped working, the bulb is still good and when I go and hit the turn signal to turn right, the blinker light, just stays on... Is there a way to fix that also? Thanks in advance!
-Cro

Cro577 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-29-2010, 05:13 PM
XJcruiser
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2009
Location: San Antonio
Posts: 1,268
If the rest of the gauges work, your cluster is fine. Check the electrical connection at the transfer case. It may be a loose connection or a short.
XJcruiser is offline  
post #3 of 4 Old 09-29-2010, 05:15 PM
Paradise XJ
Registered User
1988 MJ Comanche 
 
Join Date: Jan 2007
Location: Paradise, CA
Posts: 2,420
The blinker socket ground is probably corroded or clogged with crap...that's inside the socket. Check to see if there is hardened "grease" in there. Clean it out gently. If it breaks you'll have to replace it.

Don't know if your speedo is electric or cable run. If electric, the sensor is likely going out, it's on the transfer case. If cable driven check the length of the cable for nicks and/or corrosion and how it connects to the cluster. My cable is a little bent so it wiggles under 45 mph.

1990 XJ Laredo - White & Chrome
1988 MJ Pioneer - Metallic Green and Black
Paradise XJ is offline  
post #4 of 4 Old 09-29-2010, 05:23 PM Thread Starter
Cro577
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: Layton, Utah
Posts: 105
Okay so, I didnt know that my dad checked the blinker, but he said that he checked the blinker wire with his meter thingy (forgot what its called) and it has no power... So where would the wire most likely short...
Cro577 is offline  
Reply

Tags
speedo , tach , tachometer , turn signal , xj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
You're doing it wrong! andersaur XJ Cherokee Technical Forum 5 03-10-2009 06:17 PM
What could be wrong? lilseth0014 XJ Cherokee Technical Forum 3 03-04-2007 09:34 AM
Something wrong with Jeep's record of my vehicle - wrong build sheet prior2 XJ Cherokee Technical Forum 16 12-21-2005 04:47 AM
Something gone wrong? devile XJ Cherokee Technical Forum 1 06-12-2005 09:49 PM
WTF is wrong now?? fisher446 XJ Cherokee Technical Forum 16 05-29-2005 11:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome