Turn signals only work with headlight off - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Turn signals only work with headlight off

Savvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHutIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 12-14-2013, 12:51 AM   #1
brody1124
Registered User
1990 XJ Cherokee 
 
Join Date: May 2007
Location: Burlington,WA
Posts: 6
Turn signals only work with headlight off

OK so I have this problem i cannot figure out. Recently since winter hit i have been driving my jeep more. I have noticed that my blinkers work fine with no problems. When i turn on my running lights and headlights they do not work. They light up but do not blink. I have checked the lights and the only light i have out is the rear brake light. That will be fixed in the morning. So any ideas on what it could be, what I should check?

One other question. My blinkers flash about every 3 seconds when i have them on. Is that slow for them?


The jeep i have is a 1990 Cherokee pioneer.


Once again thanks in advance for any help.

brody1124 is offline   Reply With Quote Quick reply to this message
Unread 12-14-2013, 02:11 AM   #2
holysirsalad
Registered User
1999 XJ Cherokee 
 
Join Date: Dec 2011
Location: Kingston, ON
Posts: 306
Very very slow.

1990 has a lot of interesting quirks, take a gander through here, I'm sure you'll find a connector or ground refreshing that will help: http://www.jeepforum.com/forum/f140/...-tips-1304879/

If not it's excellent preventative maintenance.
holysirsalad is offline   Reply With Quote Quick reply to this message
Unread 12-15-2013, 01:04 PM   #3
brody1124
Registered User
1990 XJ Cherokee 
 
Join Date: May 2007
Location: Burlington,WA
Posts: 6
Thanks...that helped a lot. Was able to get it all working again.
brody1124 is offline   Reply With Quote Quick reply to this message
Unread 12-15-2013, 03:41 PM   #4
holysirsalad
Registered User
1999 XJ Cherokee 
 
Join Date: Dec 2011
Location: Kingston, ON
Posts: 306
Great to hear!
holysirsalad is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.