post #1 of Old 12-13-2013, 11:51 PM Thread Starter
brody1124
Registered User
1990 XJ Cherokee 
 
Join Date: May 2007
Location: Burlington,WA
Posts: 6
Turn signals only work with headlight off

OK so I have this problem i cannot figure out. Recently since winter hit i have been driving my jeep more. I have noticed that my blinkers work fine with no problems. When i turn on my running lights and headlights they do not work. They light up but do not blink. I have checked the lights and the only light i have out is the rear brake light. That will be fixed in the morning. So any ideas on what it could be, what I should check?

One other question. My blinkers flash about every 3 seconds when i have them on. Is that slow for them?


The jeep i have is a 1990 Cherokee pioneer.


Once again thanks in advance for any help.

brody1124 is offline  
post #2 of Old 12-14-2013, 01:11 AM
holysirsalad
Registered User
1999 XJ Cherokee 
 
Join Date: Dec 2011
Location: Kingston
Posts: 306
Very very slow.

1990 has a lot of interesting quirks, take a gander through here, I'm sure you'll find a connector or ground refreshing that will help: http://www.jeepforum.com/forum/f140/...-tips-1304879/

If not it's excellent preventative maintenance.
holysirsalad is offline  
post #3 of Old 12-15-2013, 12:04 PM Thread Starter
brody1124
Registered User
1990 XJ Cherokee 
 
Join Date: May 2007
Location: Burlington,WA
Posts: 6
Thanks...that helped a lot. Was able to get it all working again.
brody1124 is offline  
post #4 of Old 12-15-2013, 02:41 PM
holysirsalad
Registered User
1999 XJ Cherokee 
 
Join Date: Dec 2011
Location: Kingston
Posts: 306
Great to hear!
holysirsalad is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome