Turn signals not working... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 09-09-2011, 07:32 AM Thread Starter
Yojimbo
Registered User
 
Join Date: Jul 2004
Location: Ohio, USA
Posts: 40
Turn signals not working...

This is for a 92 XJ Laredo.

The turn signals stopped working yesterday. I replaced the right/left front and rear bulbs but the signal does not come on when I use the turn signal lever.

The the brake and hazard light blinkers are working and now I am not sure what else to look for.

Before they stopped working they blink very slowly and intermittently. Sometimes they would flash rapidly a few times and then go back to blinking very slowly.

I would appreciate any tips on how to further troubleshoot this issue as well as what to try next. Thanks!

Yojimbo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-09-2011, 07:41 AM
Brg0012
Registered User
1983 CJ7 
 
Join Date: Oct 2009
Location: Chattanooga,TN
Posts: 505
Right when you open the driver door under the dash, there is a relay box and the flasher relay is on the end. I know thats not SUPER helpful but I ran into the same problem on my 95.
Brg0012 is offline  
post #3 of 3 Old 09-09-2011, 11:32 AM Thread Starter
Yojimbo
Registered User
 
Join Date: Jul 2004
Location: Ohio, USA
Posts: 40
I just popped in a new flasher fuser and it fixed it.


Thanks Brg0012!
Yojimbo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Gauges and turn signals not working. Showtime3492 XJ Cherokee Technical Forum 0 06-13-2010 03:35 PM
Turn signals not working............ g26 XJ Cherokee Technical Forum 1 05-26-2009 09:37 PM
turn signals not working cardana24 XJ Cherokee Technical Forum 4 10-09-2006 10:56 AM
Turn signals stopped working Jenniegirl XJ Cherokee Technical Forum 3 03-02-2006 07:00 PM
99 turn signals not working 46CJ2A XJ Cherokee Technical Forum 4 01-10-2005 02:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome