Thumping noise when hitting brakes...Not Pulsating - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Thumping noise when hitting brakes...Not Pulsating

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line~Artec JK 1 TON SWAP~Advance Adapters SYE Kits

Reply
Unread 04-21-2012, 04:35 PM   #1
LrgLnrd
Registered User
1998 XJ Cherokee 
 
Join Date: Feb 2012
Location: Pittsburgh, Pensylvania
Posts: 39
Thumping noise when hitting brakes...Not Pulsating

So I finally got some of my front end fixed which included new u-joints on both sides of the axles and the right front wheel bearing. I had/have a really bad thumping when I hit my brakes that I thought was my left front u-joint but it still remains after replacing. When I had my brakes apart everything looked to be in proper working order good pads, rotors were decent and their not warped no grabbing or dragging sensation.
After some diagnosing I can say that if I use my e-brake to slow down to a stop there is no thump and it feels to coming from the left front when I do use my brakes to stop, also it is speed sensitive the slower I go the longer of a pause before the thump.
I shook my front end down and checked all my fluids in the diff. and transfer case..(This was low) Could this be the culprit????
I also have the "notorious" flex plate thump but thats not what I am hearing...I dont think so...
Any info would be really appreciated, I am gonna try to check it out tomorrow on a lift with it in 4wd hitting the brakes while in the air but not sure if Im gonna have time to check it out.
Thanks Again,
Greg

LrgLnrd is offline   Reply With Quote Quick reply to this message
Unread 05-28-2013, 09:30 AM   #2
XJNKY
Registered User
1998 XJ Cherokee 
 
Join Date: Mar 2010
Location: , Central KY
Posts: 471
I know this is over a year old, but may I ask, did you ever find out what the culprit was? I've been chasing exactly the same thing. I've replaced both front wheel bearings, and brakes. The only thing I have left to look at is my tires, and they're fairly new (5K miles?) and they're not cheap tires either (Duratracs).

Just curious if you ever tracked down your thump.
XJNKY is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.