Symptoms of a bad TPS? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Symptoms of a bad TPS?

RIGID LED Light Blowout Sale - All Sizes, All Series, all Truc-Lite LED Headlights! OCONEE OFF-ROAD 706-534-9955Jeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 09-28-2013, 10:02 AM   #1
Jeepnbo
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2012
Location: paw paw, mi
Posts: 212
Symptoms of a bad TPS?

Heres the deal. 99 4.0 auto. Once i first fire it up and drive somewhere its fine but if i park, shut it off, and go to leave again, it bogs down and suddenly clears up and is fine. TPS??

Jeepnbo is offline   Reply With Quote Quick reply to this message
Unread 09-28-2013, 12:09 PM   #2
SaarXJ
Registered User
2001 XJ Cherokee 
 
Join Date: Sep 2013
Location: MB, IL
Posts: 54
It might be the TPS, but I believe it is not.
I would start with cleaning the IAC.
Bad injectors may cause tough starting while the engine is hot as well.
__________________
2001 Jeep XJ
2001 Mitsubishi Montero
My [URL="http://www.pajero.guru"]Montero DIY[/URL] site
While not playing with my Jeep, I play other [URL="http://www.myplayyard.com/car-games"]racing games[/URL] or fixing my Alfa Spider :)
SaarXJ is offline   Reply With Quote Quick reply to this message
Unread 09-28-2013, 12:15 PM   #3
psychoteen101
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2010
Location: Gurnee
Posts: 661
Check your fuel pressure when the bog occurs. Check engine light on? Even if its not, see if any codes are stored. Might have a code pending if this started recently
__________________
1996 Jeep Cherokee- Project-- Rusty's 8in long arm, SYE kit, Teraflex driveshaft, Cragar soft 8's 15x10 with 33x12.5 Firestone Destination MT's, Eaton Tru Trac in the front
psychoteen101 is offline   Reply With Quote Quick reply to this message
Unread 09-28-2013, 06:54 PM   #4
Jeepnbo
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2012
Location: paw paw, mi
Posts: 212
No cel that i know of. Last time i had the code ran it was PO705 trans range sensor circuit?? I'll look into cleaning the IAC
Jeepnbo is offline   Reply With Quote Quick reply to this message
Unread 10-01-2013, 08:06 AM   #5
robtco99
Registered User
2001 XJ Cherokee 
 
Join Date: Sep 2010
Location: Cincinnati
Posts: 198
The TPS also controls trans shifts. When mine went bad the trans would shift kind of hard. As soon as I replaced it the trans shifted smooth.
__________________
2001 amber fire cherokee sport 4x4, 2 in lift, 30x9.50 generals, 174 ion wheels, pretty much stock.
robtco99 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.