strange leak, part DEUX!? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > strange leak, part DEUX!?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSteering and more from Ruffstuff!The Original 3/8" Ruffstuff Diff Cover!

Reply
Unread 12-10-2004, 05:54 PM   #1
xjrubicon
Registered User
 
Join Date: Sep 2004
Location: Grand Rapids, MI
Posts: 150
strange leak, part DEUX!?

hey everyone! I had a post a while back about a strange oil leak that turned out to be resulting from (through some very good advice) a clogged PCV valve. I replaced all the breather lines (found out my '91 XJ actually had a '94 valve cover in the process ) and everything was back working awsome until it started doing it again today. I was on the freeway and noticed a slight loss in power, got home, popped the hood and grabbed my K&N to find it soaked in oil . So, now I've deduced that I probably have a more serious problem than just a clogged pcv...If anyone has any advice as to how deep I need to tear into this monkey I would really appreciate it. AND...Should I just stroke it while I have the chance? hehehe

thanks all! sorry for the long post.


'91 XJ Laredo 4.0 HO w/194000mi
5.5" RE XD Lift kit
W/ AA HD SYE & RE CV Driveshaft
285 75/R16 Goodyear MT/Rs on Rubi Moabs
HP D30 front
D35 rear, super35 shafts w/ lockright locker
rear disc brake conversion
ACOS up front to level out the ride
K&N Air Filter
XJ Armor 62mm throttle body
2 JJUSA stickers (+5hp each)
and a bunch of other stuff...


xjrubicon is offline   Reply With Quote
Unread 12-10-2004, 07:51 PM   #2
BrunoS
Registered User
 
Join Date: Aug 2004
Location: South Bay Los Angeles, CA
Posts: 2,534
if it runs good, why bother digging in?

the oil on the K&N could be the k&n oil itself.

if it runs well, gets good mileage, and does not eat oil every 1000 miles, then it should be ok...there are some FAQ's and posts on "oil in air filter" and how to fix it. I think your slight loss in power is from oily filter. clean it out, and see what happens.

you get some leak indicator (flourrescent marker) from parts store, add it to oil, and then check K&N with blacklight to see if indeed it is engine oil.

Serious blow-by could be sticky rings...in this case :Seafoam: might free them....add it to gas, but I would be careful against dumping it down throttle body. you have high mileage, but otherwise sounds ok
BrunoS is offline   Reply With Quote
Unread 12-14-2004, 04:52 PM   #3
xjrubicon
Registered User
 
Join Date: Sep 2004
Location: Grand Rapids, MI
Posts: 150
more info

the seafoam idea is interesting. I've never heard of it before (I'm not a mechanic by any means). But perhaps I didn't really convey the problem very well in my first post. When I said there was oil in my k&N I'm talking about brown 5W30 dripping out of the bottom of the filter and pooling where the original air box used to be! Something has caused the positive crankcase ventilation valve to plug creating an overwhelming amount of oil pressure in the CC resulting in a bad leak out the breather tube....this is the second time it's clogged in a month and I'm now wondering what the root of the problem could be. As I said before I replaced all the breather lines )as outline in the tech section of madxj.com ) and it was working fine again for about a month but now I'm stuck again. SOMEONE PLEASE HELP! I'M ON THE VERGE OF TAKING IT TO A SHOP....and the thought doesn't thrill me...

thanks, mike.
__________________

Hey you wanna buy a boat man?
It's a deal. I swear to God it is.
_________________________


'91 XJ Laredo 4.0 HO 200000+mi | 5.5" RE XD | AA SYE & RE CV Driveshaft | 315 75/R16 MT/Rs | Moab wheels | 1.25" spacers | HP D30/Aussie/4.56s | D44/Cromo shafts/E-Locker/4.56s | JKS Adjustable Rear Bumpstops | Skid Row Engine/tranny & transfer case skid | Magnaflow Hi-Flow Cat/super turbo catback | XJ Armor 62mm throttle body | 9" K&N | 2000WJ brake booster and a bunch of other stuff...
xjrubicon is offline   Reply With Quote
Unread 12-14-2004, 06:05 PM   #4
Big Dawg 23
Registered User
 
Join Date: Oct 2004
Location: Northfield, MN
Posts: 48
My 90Xj does the same thing. It is oil blow by. Go to this link it is awesome.


http://www.off-road.com/jeep/cherok...0ltr/blowby.htm
http://www.off-road.com/jeep/cherok...over/cover.html


Thank Balloo93 for them
__________________
[FONT=Georgia][COLOR=Indigo]90 XJ 4DR Laredo
4.0L AW4
215,000mi and Strong As Ever
As Stock as they Come[/COLOR][/FONT]
Big Dawg 23 is offline   Reply With Quote
Unread 12-14-2004, 07:48 PM   #5
xjrubicon
Registered User
 
Join Date: Sep 2004
Location: Grand Rapids, MI
Posts: 150
I Don't Like Spam!!!

Quote:
Originally Posted by Big Dawg 23
My 90Xj does the same thing. It is oil blow by. Go to this link it is awesome.


http://www.off-road.com/jeep/cherok...0ltr/blowby.htm
http://www.off-road.com/jeep/cherok...over/cover.html


Thank Balloo93 for them

Sorry guys I don't mean to be a broken record but I followed those exact instructions last month when I thought I fixed the problem. I replaced all the vac lines with the complete mopar kit and took the valve cover off and cleaned everything. It hadn't leaked a drop until last week. It is now undriveable again and leaking about a quart every 100 miles...I'm baffled and all the write-ups say is ;"this is the magical fix" but they don't say what to do if it doesn't work. If only someone with some advanced knowledge of the inner workings of the I-6 could shed some light...

Oh well, guess I'll just have to drive the ZJ instead for a while...
__________________

Hey you wanna buy a boat man?
It's a deal. I swear to God it is.
_________________________


'91 XJ Laredo 4.0 HO 200000+mi | 5.5" RE XD | AA SYE & RE CV Driveshaft | 315 75/R16 MT/Rs | Moab wheels | 1.25" spacers | HP D30/Aussie/4.56s | D44/Cromo shafts/E-Locker/4.56s | JKS Adjustable Rear Bumpstops | Skid Row Engine/tranny & transfer case skid | Magnaflow Hi-Flow Cat/super turbo catback | XJ Armor 62mm throttle body | 9" K&N | 2000WJ brake booster and a bunch of other stuff...
xjrubicon is offline   Reply With Quote
Unread 12-14-2004, 10:07 PM   #6
MGrobe
Man In Black
 
MGrobe's Avatar
1998 XJ Cherokee 
 
Join Date: Oct 2003
Location: Chicago-area (Western Suburbs)
Posts: 2,293
All I can think of that others have done is to install an oil catch can between the CCV valve and the air cleaner. This would catch the oil prior to filling up your air cleaner. I know a write-up exists somewhere on how to fab your own, but a commercially available product that performs a similar function on my buddies Ram 360 is located here: http://www.condensator.com/
MGrobe is offline   Reply With Quote
Unread 12-15-2004, 12:43 PM   #7
xjrubicon
Registered User
 
Join Date: Sep 2004
Location: Grand Rapids, MI
Posts: 150
I think I'll try that and see how she runs. I would definitely like to fix the problem for good but if this works for now then I will probably just build a stroker and drop it in and then take my old block and rebuild it and drop that in my ZJ...so if anyone who reads this could spare some change I'm setting up a paypal account and taking donations..."will wheel for gas money"! Help a brother out!...
__________________

Hey you wanna buy a boat man?
It's a deal. I swear to God it is.
_________________________


'91 XJ Laredo 4.0 HO 200000+mi | 5.5" RE XD | AA SYE & RE CV Driveshaft | 315 75/R16 MT/Rs | Moab wheels | 1.25" spacers | HP D30/Aussie/4.56s | D44/Cromo shafts/E-Locker/4.56s | JKS Adjustable Rear Bumpstops | Skid Row Engine/tranny & transfer case skid | Magnaflow Hi-Flow Cat/super turbo catback | XJ Armor 62mm throttle body | 9" K&N | 2000WJ brake booster and a bunch of other stuff...
xjrubicon is offline   Reply With Quote
Unread 12-15-2004, 02:08 PM   #8
Big Dawg 23
Registered User
 
Join Date: Oct 2004
Location: Northfield, MN
Posts: 48
Not to put a damper on the parade but it youi have already down as the links suggestion. I would look into if the Rings are gone. When one goes it will pressurize you oil pan. With the Vehicle running remove the filler cap and watch for a puff of smoke repeatedly like it is a train. I had two mechanics tell me it is a ring issue. These are about the only option on why it would go into the air filter.
__________________
[FONT=Georgia][COLOR=Indigo]90 XJ 4DR Laredo
4.0L AW4
215,000mi and Strong As Ever
As Stock as they Come[/COLOR][/FONT]
Big Dawg 23 is offline   Reply With Quote
Unread 12-16-2004, 05:27 PM   #9
xjrubicon
Registered User
 
Join Date: Sep 2004
Location: Grand Rapids, MI
Posts: 150
that is exactly the kind of thing I've been wanting to hear all along...Thank you. I'll try that right now.

-mike.
__________________

Hey you wanna buy a boat man?
It's a deal. I swear to God it is.
_________________________


'91 XJ Laredo 4.0 HO 200000+mi | 5.5" RE XD | AA SYE & RE CV Driveshaft | 315 75/R16 MT/Rs | Moab wheels | 1.25" spacers | HP D30/Aussie/4.56s | D44/Cromo shafts/E-Locker/4.56s | JKS Adjustable Rear Bumpstops | Skid Row Engine/tranny & transfer case skid | Magnaflow Hi-Flow Cat/super turbo catback | XJ Armor 62mm throttle body | 9" K&N | 2000WJ brake booster and a bunch of other stuff...
xjrubicon is offline   Reply With Quote
Unread 12-16-2004, 09:46 PM   #10
xjrubicon
Registered User
 
Join Date: Sep 2004
Location: Grand Rapids, MI
Posts: 150
choo choo!!!

She's not just puffin' every once in a while. She looks like a steam engine smoke stack! WILL THIS SEAFOAM STUFF I KEEP HEARING ABOUT FIX THE PROBLEM? WHAT IS IT AND WHAT DOES IT DO? j/k hahaha Thank you all, sincerely. now I know what is causing all this pressure....

-case closed-

-mike.
__________________

Hey you wanna buy a boat man?
It's a deal. I swear to God it is.
_________________________


'91 XJ Laredo 4.0 HO 200000+mi | 5.5" RE XD | AA SYE & RE CV Driveshaft | 315 75/R16 MT/Rs | Moab wheels | 1.25" spacers | HP D30/Aussie/4.56s | D44/Cromo shafts/E-Locker/4.56s | JKS Adjustable Rear Bumpstops | Skid Row Engine/tranny & transfer case skid | Magnaflow Hi-Flow Cat/super turbo catback | XJ Armor 62mm throttle body | 9" K&N | 2000WJ brake booster and a bunch of other stuff...
xjrubicon is offline   Reply With Quote
Unread 12-17-2004, 07:05 AM   #11
JTruel
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2003
Location: Broken Arrow, OK
Posts: 412
there are some old school tricks to loosen sticky rings, but I don't think they will help you since your XJ wasn't stored..

In the past we have used Marvel Mystery Oil, tranny fluid and kerosene down the spark plug holes to unfreeze rings.. doesn't hurt anything but your catalytic converter....
In your case, I would remove the engine, take the head and oil pan off and re-ring/re-bearing the thing... you can try some of the snake oil stuff out there like engine restore, but it is a stop gap AT BEST.
__________________
2000 XJ Classic
2005 LJ
JTruel is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.