Squealing/squeaking noise until I press brakes? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Squealing/squeaking noise until I press brakes?

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 03-24-2012, 06:47 AM   #1
mreid10
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2012
Location: Westminster, MA
Posts: 97
Squealing/squeaking noise until I press brakes?

My 1996 xj was in the shop for the past two weeks because they put a couple washers on a sway bar bolt and then they replaced my left side "heim" joint which is just a tie rod and when I drove my jeep away from the shop yesterday there is this VERY loud squealing/squeaking noise when I drive but it stop when I press the brake. Of course it does get louder as I drive faster and it sounds like it's coming from the front driver's side. It definitely did not make this sound when I brought it to the shop but it did sit there for two weeks while the heim joint was shipped in. It's so loud I feel bad for anyone I drive by haha. Any ideas?

mreid10 is offline   Reply With Quote Quick reply to this message
Unread 03-24-2012, 11:49 AM   #2
AZ Jeff
Web Wheeler
2014 JK Wrangler 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona, AZ
Posts: 7,427
If it goes away when the brakes are depressed (even slightly), it sounds like caliper pad squeal is the issue. They make a goop that can be applied between the pad and the caliper to lessen/eliminate the sound.

However, it's odd for such a noise to start up unless brake work was done recently. Is that the case?
__________________
AZ-Jeff
1992 XJ -- stock (RIP)
2000 XJ -- lots of basic mods. Sold to fellow forum member. I miss it.
2014 JK -- the project is just starting!
AZ Jeff is offline   Reply With Quote Quick reply to this message
Unread 03-24-2012, 03:55 PM   #3
mreid10
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2012
Location: Westminster, MA
Posts: 97
No one has touched the brakes and all the mechanic did was the heim joint and sway bar bolt.
mreid10 is offline   Reply With Quote Quick reply to this message
Unread 03-24-2012, 03:57 PM   #4
Umbra0101
Registered User
1997 TJ Wrangler 
 
Join Date: Dec 2011
Location: Big Run, PA
Posts: 64
Thats usually the wear indicator, you most likely need breaks.
__________________
[FONT="Showcard Gothic"][COLOR="Blue"]Last night, my girl started smoking, so I slowed down and lubed her up a little.[/COLOR][/FONT]
Umbra0101 is offline   Reply With Quote Quick reply to this message
Unread 03-24-2012, 05:58 PM   #5
N8N
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2012
Location: Sterling, VA
Posts: 224
eh, my F*rd pickup truck makes a noise just like that and I've been shafted by so many shops I've given up on it. (wanna buy a truck? Seriously, soon as I get the Jeep sorted, it's GONE. I have literally put more than the value of the truck into having people misdiagnose the problem and replace stuff that has nothing to do with the issue.) The ONLY thing related to the front end that isn't brand shiny new is the spindles themselves (well, and the I-beams, but they couldn't cause the noise I'm hearing.) So my amazing powers of deduction tell me that one or both of the spindles must have been worn by bad wheel bearings in the past to the point that the rotors wobble as they turn, causing that obnoxious noise.

So... question is, have you checked your hub assemblies for play?
N8N is offline   Reply With Quote Quick reply to this message
Unread 03-24-2012, 07:03 PM   #6
mreid10
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2012
Location: Westminster, MA
Posts: 97
Nah I literally got it back last night but that's a good start thanks.
mreid10 is offline   Reply With Quote Quick reply to this message
Unread 03-27-2012, 06:44 PM   #7
mreid10
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2012
Location: Westminster, MA
Posts: 97
Someone put the shield on incorrectly and it messed up my caliper, of course!
mreid10 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.