Slow Start after long drive - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 04-15-2010, 03:00 PM Thread Starter
duder123
Registered User
1997 XJ Cherokee 
 
Join Date: Apr 2010
Location: chicago
Posts: 1
Slow Start after long drive

So, I've recently had NSS troubles (i.e. no cranking, starting in neutral, reverse lights, etc...). I tried to clean it the other day, but could not get it off without possibly breaking it.

Around this same time (both before and after NSS attempt) I started noticing that occasionally, after driving for a while, I would get a slow start. It will crank fine, but I can't get it to fire up unless I really give it a lot of gas.

It never happens on a cold start though... only after I have driven it a bit, stopped, and then try to start back up. Seems more frequent on long trips.

should i start with the CPS? or Cam position sensor?

duder123 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-16-2010, 10:08 AM
JBassXJ
Registered User
 
JBassXJ's Avatar
1998 XJ Cherokee 
 
Join Date: Mar 2004
Location: Texas
Posts: 1,211
I know a better internet mechanic will come through, but I'm thinkin that possibly the NSS is either just gettin' worse coupled with you may need to check the pressure at your fuel rail. Definitely get that NSS cleaned out and re-installed though.... I know their's a write-up on here somewhere...

soon to be enforced in close to all threads....

Quote:
Originally Posted by Blake
Pics or ban.
JBassXJ is offline  
Reply

Tags
cps , nss , slow start , won't start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
slow to start damifinowfish XJ Cherokee Technical Forum 2 04-04-2010 05:49 PM
Slow Start jimbosz07 XJ Cherokee Technical Forum 4 03-19-2010 06:07 AM
Slow to Start rockntheXJ XJ Cherokee Technical Forum 13 09-21-2009 11:13 AM
Slow to start Dragasoni XJ Cherokee Technical Forum 10 10-14-2007 08:23 AM
Slow to start Dragasoni MJ Comanche Technical Forum 0 10-12-2007 10:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome