runs rough after a hard launch - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > runs rough after a hard launch

New Product Release: Flowmaster Force II Dual Tailpipe AxlNew Product Release: Flowmaster Force II Dual Tailpipe AxlUSA Made JK Rear Axles!!! Revolution Gear and Axle

Reply
Unread 12-12-2006, 03:34 PM   #1
StreetJeep
Registered User
 
Join Date: Sep 2006
Location: Lake Orion, Mi
Posts: 46
runs rough after a hard launch

I haven't read anywhere about this but here goes. Has had a tune up within 1500 miles using Champion truck plugs, copper connector cap and rotor. Wires are good. Checked codes and nothing. Checked the TPS and it works smoothly with no dead spots. But after I launch over half pedal from a light it will idle rough for about a week. Then it slowly idles better after that. I'm sort of at a loss. Could it be the injectors? Possibly the fuel filter? If anyone has experienced this let me know what you did to fix it. Thanks in advance.

StreetJeep is offline   Reply With Quote
Unread 12-13-2006, 06:39 PM   #2
StreetJeep
Registered User
 
Join Date: Sep 2006
Location: Lake Orion, Mi
Posts: 46
Anyone????
StreetJeep is offline   Reply With Quote
Unread 12-13-2006, 07:59 PM   #3
georgesxj
Registered User
 
Join Date: May 2005
Location: Raleigh NC
Posts: 203
It may be that the fuel filter is clogged up so when you hit the gas it pushes trash into the line and you have to wait till it dislodges itself. The filter should be changed every year or two anyway so it wouldn't hurt to put a new one in and try it out. There only like 10 bucks if you have a pre 97'. If you have a newer jeep it's inside the tanke and a little more tricky to change.
__________________
92 Sport
RE 3.5" super flex
31 x 10.5 Dunlop Mudrovers
Custom rack and rails
Hella 4000's on top
and lots of problems to still work out

We all like jeep pics
georgesxj is offline   Reply With Quote
Unread 12-13-2006, 08:05 PM   #4
Rock Kustoms
Registered User
 
Join Date: Feb 2005
Location: Wolcott, CT
Posts: 3,845
how about a year, motor, tranny, tcase etc
Rock Kustoms is offline   Reply With Quote
Unread 12-13-2006, 09:23 PM   #5
Haleyes
Registered User
1996 XJ Cherokee 
 
Join Date: Jun 2005
Location: 2nd bedroom on the left
Posts: 1,425
Don't launch hard?

__________________
96' XJ, 33's and 4.88's


http://img.photobucket.com/albums/v6...d/100_5140.jpg
Haleyes is offline   Reply With Quote
Unread 12-14-2006, 02:39 PM   #6
StreetJeep
Registered User
 
Join Date: Sep 2006
Location: Lake Orion, Mi
Posts: 46
Its a 92 Limited, aw4, np242. The fuel filter is a possibility. Thats going to get changed next.

Haleyes,
I'm not an old man. Unless you ask my wife. Then I am an old man. But I'm still a kid at heart. So the floorings will continue.
StreetJeep is offline   Reply With Quote
Unread 12-15-2006, 05:36 PM   #7
StreetJeep
Registered User
 
Join Date: Sep 2006
Location: Lake Orion, Mi
Posts: 46
Okay, changed the fuel filter. Still idles rough. The filter that was in there looked to be no more than a couple years old. Could bad injectors cause this? Or possibly a faulty MAP sensor or O2 sensor not throwing a code? Did this year have a CPS?
StreetJeep is offline   Reply With Quote
Unread 12-15-2006, 07:55 PM   #8
SlimGoaty
Registered User
1997 XJ Cherokee 
 
Join Date: Jan 2005
Location: Centralia, Washington
Posts: 1,134
give her a good seafoam and clean the TB and IAC just to make sure everyone is happy.
__________________

My buildup on CherokeeForum

97 XJ 4.0, AW4, 231, RE 5.5, Tom Woods DS, AA SYE, 35x12.50 KM2,
Upgraded Harness, PIAA bulbs, Rustys Tie-Rod, L&L Fab bumper,
Quadratec 9500i Winch, Aussie locker, 4.88's
SlimGoaty is offline   Reply With Quote
Unread 12-16-2006, 10:30 AM   #9
StreetJeep
Registered User
 
Join Date: Sep 2006
Location: Lake Orion, Mi
Posts: 46
I did both of those. Sorry forgot to write that. I cleaned the throttle body and IAC then ran a bottle of sea foam through it. Half in the tank and the other half in the throttle body. My neighbor saw the smoke and came running up the hill.
StreetJeep is offline   Reply With Quote
Unread 12-16-2006, 10:41 AM   #10
Matt Gertsch
www.lp.org
 
Matt Gertsch's Avatar
1999 XJ Cherokee 
 
Join Date: Jan 2005
Location: Nor Cal
Posts: 8,862
Check your cat.
__________________
Derpy Hooves for President in 2012
Matt Gertsch is offline   Reply With Quote
Unread 12-17-2006, 06:21 PM   #11
StreetJeep
Registered User
 
Join Date: Sep 2006
Location: Lake Orion, Mi
Posts: 46
No I dont think the cats a problem.
StreetJeep is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.