Rough Idle, Stalls - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Rough Idle, Stalls

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRough Country Jeep Suspension Deals at Rockridge 4WD!Engo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 03-05-2013, 02:13 PM   #1
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 112
Rough Idle, Stalls

I recently put a new O2 sensor in my 2000 Cherokee because the CEL was on for the Bank 1 Sensor 2 O2 sensor. The CEL will now go off maybe once a week for a day and come back on. It will also not clear. Now when I try to start my truck in the morning it sounds like it doesn't want to start then has a rough idle till it's warmed up. Does anyone have any suggestions? Is it possible that I might have just mis-wired the O2 sensor?

StevenXJ is offline   Reply With Quote
Unread 03-05-2013, 05:15 PM   #2
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,635
What Check Engine Light trouble codes were downloaded before the O2 sensor swap ? Were they all fixed ?

What trouble codes do you have now ? Your Jeep is trying to tell you what is wrong.
__________________
.

According to the National Shooting Sports Foundation, AR-15 sporting rifles account for nearly 20% of all U.S. firearms sales.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline   Reply With Quote
Unread 03-05-2013, 11:43 PM   #3
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 112
I can't remember the code number, but it was for the bank 1 sensor 2. Like too much voltage and something else.
StevenXJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.