Quick question on steering - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Quick question on steering

Ring & Pinion's, Lockers, 4340 Axles, Install Kits, BaStainless Steel Door Hinge PinsPoly Door Hinge Bushings

Reply
Unread 01-29-2014, 11:55 AM   #16
dgood
Registered User
1995 XJ Cherokee 
 
Join Date: May 2013
Location: Virgina Beach, Virginia
Posts: 44
I had the same problem. Changed everything to do with suspension and steering up front (control arms, steering gear box, power steering pump, springs, shocks, tie rod ends, track bar, steering stabilizer and some other parts I don't what they are called). Tried to adjust the steering gear box and it made it worse. Exchanged the steering box for another new one and it is all better now. Check to make sure everything is tight before you do it. The steering gear box is a couple hour job and that bugger is heavy when you trying to line up the bolts all by yourself. Mine is a 95 with 126000 miles.

dgood is offline   Reply With Quote
Unread 01-29-2014, 01:50 PM   #17
JBlue
Member
2000 XJ Cherokee 
 
Join Date: Jun 2013
Location: Westchester, NY
Posts: 183
Quote:
Originally Posted by dgood
I had the same problem. Changed everything to do with suspension and steering up front (control arms, steering gear box, power steering pump, springs, shocks, tie rod ends, track bar, steering stabilizer and some other parts I don't what they are called). Tried to adjust the steering gear box and it made it worse. Exchanged the steering box for another new one and it is all better now. Check to make sure everything is tight before you do it. The steering gear box is a couple hour job and that bugger is heavy when you trying to line up the bolts all by yourself. Mine is a 95 with 126000 miles.
Thanks, I wish there was a better way of diagnosing it. I know I need a new pump and it was running pretty dry when I bought it due to leaking lines so perhaps that affected the gear box. I have no clue. Ill take a look at the track bar this weekend and in a few months replace the box and pump when I do my cooling system and front main seal.
JBlue is offline   Reply With Quote
Unread 01-29-2014, 07:24 PM   #18
skyway0018746
Registered User
2000 XJ Cherokee 
 
Join Date: Jan 2009
Location: ct
Posts: 715
Best way I found is with the engine on have some one jerk the wheel back and forth and look for play in the front end.
__________________
7" long arm lift, HNT sye , herculined inside, bush wacker fender flares now geared and locked !!!
62 mm bored throttle body's fs - pm
skyway0018746 is online now   Reply With Quote
Unread 01-30-2014, 05:19 AM   #19
JBlue
Member
2000 XJ Cherokee 
 
Join Date: Jun 2013
Location: Westchester, NY
Posts: 183
Quote:
Originally Posted by skyway0018746
Best way I found is with the engine on have some one jerk the wheel back and forth and look for play in the front end.
Thanks skyway, I'll try that this weekend. I feel it's the gearbox. It needs a new pump from running dry when i bought it (bad hose) so I wonder if that can hurt the gear. Since then the fluids been fine. I'll self-diagnose again this weekend.
JBlue is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.