Picture wanted! Renix knock sensor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Picture wanted! Renix knock sensor

Savvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHutIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 05-10-2009, 03:23 PM   #1
keepishop
Registered User
1989 XJ Cherokee 
 
Join Date: Oct 2008
Location: Seattle
Posts: 3,372
Picture wanted! Renix knock sensor

I think my knock sensor is broken, but the problem is that I have only found it once. Does anyone have a diagram of where it is, or a picture that shows it? Google has failed me, and I'm starting to feel really dumb about not being able to find it on my block again.

__________________

Current: Black 89 limited, dakota bastard pack, zj coils, 1.5" lift, open cooling swap, bronco 2 carrier, rad fan switch
Rest in Pieces: Red 1990 cherokee dana30/8.25 - v8 zj coils & s10 bastard pack 2.5" lift - 31x10.5r15 tires - v8 zj tierod

Quote:
Originally Posted by talentjeep View Post
Bleed or Quit.
jf irc @ irc.freenode.net #jeepforum
keepishop is offline   Reply With Quote Quick reply to this message
Unread 05-10-2009, 03:59 PM   #2
Ed Rico
Senior Member
1997 XJ Cherokee 
 
Join Date: Jun 2007
Location: Terre Haute, IN
Posts: 526
From RockAuto.com:



-Ed Rico
Ed Rico is offline   Reply With Quote Quick reply to this message
Unread 05-10-2009, 07:58 PM   #3
keepishop
Registered User
1989 XJ Cherokee 
 
Join Date: Oct 2008
Location: Seattle
Posts: 3,372
Well, I found it again today and took pictures. I'll post them later when I'm on my laptop.

For those that care, the knock sensor is located on the driver side of the block just to the right of the motor mount. Honestly, why have I never seen that documented before?
__________________

Current: Black 89 limited, dakota bastard pack, zj coils, 1.5" lift, open cooling swap, bronco 2 carrier, rad fan switch
Rest in Pieces: Red 1990 cherokee dana30/8.25 - v8 zj coils & s10 bastard pack 2.5" lift - 31x10.5r15 tires - v8 zj tierod

Quote:
Originally Posted by talentjeep View Post
Bleed or Quit.
jf irc @ irc.freenode.net #jeepforum
keepishop is offline   Reply With Quote Quick reply to this message
Unread 05-10-2009, 09:13 PM   #4
Saudade
Registered User
1988 XJ Cherokee 
 
Join Date: Jun 2008
Location: SoCal
Posts: 1,381
http://www.jeepforum.com/forum/showt...t=knock+sensor
Saudade is offline   Reply With Quote Quick reply to this message
Unread 05-11-2009, 10:59 AM   #5
keepishop
Registered User
1989 XJ Cherokee 
 
Join Date: Oct 2008
Location: Seattle
Posts: 3,372


Mine is a different style. I plugged the cable back onto the terminals, and since then it has been running a little funny, I'll have to check some schematics and see what I did wrong. Probably backwards.
__________________

Current: Black 89 limited, dakota bastard pack, zj coils, 1.5" lift, open cooling swap, bronco 2 carrier, rad fan switch
Rest in Pieces: Red 1990 cherokee dana30/8.25 - v8 zj coils & s10 bastard pack 2.5" lift - 31x10.5r15 tires - v8 zj tierod

Quote:
Originally Posted by talentjeep View Post
Bleed or Quit.
jf irc @ irc.freenode.net #jeepforum
keepishop is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 09:37 AM   #6
tommyp77
Registered User
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: Windsor
Posts: 14
Quote:
Originally Posted by keepishop View Post


Mine is a different style. I plugged the cable back onto the terminals, and since then it has been running a little funny, I'll have to check some schematics and see what I did wrong. Probably backwards.
Now i have a problem where i found this sensor but i cant find the cables or wire thats supposed to plug onto it. Where is the wires originating from? Anyone have pics of that, so i might be able to trace the problem back and see if my wire even exits?
THank you for all the help in advance!
tommyp77 is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 09:50 AM   #7
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,322
It probably won't affect how it runs anyway if you have a driveability problem. All it does is send a signal, that it generates only when it hears pinging, to the ECU so the ECU will retard the timing a bit.
cruiser54 is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 09:53 AM   #8
4jeepers
Registered User
1999 WJ 
 
Join Date: Jul 2008
Location: Lancaster, CA USA
Posts: 375
Junkyard part. Unless they are physically damaged or the wires broken they rarely go bad! From your picture I would say that the molded plug on the sensor is broken off, the plug hanging below the sensor should be the connection to the sensor!
4jeepers is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 09:56 AM   #9
Saudade
Registered User
1988 XJ Cherokee 
 
Join Date: Jun 2008
Location: SoCal
Posts: 1,381
What year? The knock sensor was eliminated in '91 and are specific to Renix.
Saudade is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 10:20 AM   #10
tommyp77
Registered User
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: Windsor
Posts: 14
Well thats not my pic, i just used the pic from post above, i dont have a wire hanging there. My jeep is a 94 yj 4.0.
Thank you
The problem is my mil is on and the jeep sputters on acceleration, and its eating a bit too much.
Going to have my mil diagnosed today. It might not even be that. But like Saudade writes, i might not even have it?
tommyp77 is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 06:11 PM   #11
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,322
You don't have it. What is your CEL indicating?
cruiser54 is offline   Reply With Quote Quick reply to this message
Unread 05-15-2010, 06:22 PM   #12
tommyp77
Registered User
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: Windsor
Posts: 14
Well after getting the scan, it indicated 3 things, my alternator, something with the ac compressor(which i know i dont have) and the tps.
I had him clear it cause alternator i changed previous weekend, and i put a relay into the ac slot on fuse panel just so its there(doubt it makes a difference)
On second scan, only the tps came up.
Took $50 for new tps sensor and 5 min to change, and the light went out and jeep runs 10x better!!, No more sputtering on acceleration.
I guess i only have the knock sensor on the block cause its originally from a cherokee, i wasnt sure if the one i droped out months back had one or not.
Guess i had it pegged wrong.
Thank you all!
tommyp77 is offline   Reply With Quote Quick reply to this message
Unread 05-16-2010, 02:38 PM   #13
dover21
Registered User
2007 JK Wrangler 
 
Join Date: Feb 2009
Location: Enterprise, Alabama
Posts: 2,297
Quote:
Originally Posted by keepishop View Post


Mine is a different style. I plugged the cable back onto the terminals, and since then it has been running a little funny, I'll have to check some schematics and see what I did wrong. Probably backwards.
I just replaced mine the other day. In your pic yours is broke just like mine. The pics from Rockauto are correct for the new one. Once you disconnect the old one and install the new you'll see that the plugs match up perfectly.
__________________
There is a way out of everything, man. Just keep your pecker hard and your powder dry and the world will turn. King, Platoon

We hold these truths to be self-evident, that all men are created equal, that they are endowed by their Creator with certain unalienable Rights, that among these are Life, Liberty and the pursuit of Happiness.
dover21 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.