oil pressure sending unit, coolant temp unit - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 01-29-2006, 02:24 PM Thread Starter
h2rescue
Registered User
 
h2rescue's Avatar
 
Join Date: Nov 2005
Location: Nicholson, PA
Posts: 190
oil pressure sending unit, coolant temp unit

which oil pressure unit do i need, i have a 96 sport with the gauge, the store offers 1 and 2 wire, i dont wanna buy the wrong one its 25 minutes away .

and where is the engine temp sending unit for the dash gauge located?

h2rescue is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-29-2006, 05:45 PM
BrunoS
Registered User
 
Join Date: Aug 2004
Location: South Bay Los Angeles, CA
Posts: 2,534
yours for the full gauge cluster would be a 2-wire one.

the one-wire one simply sends a pressure/no pressure signal switch, at less than 5 psi, the points touch and your oil warning light comes on.

the full-gauge sender has an actual spring and resistor that is hooked to a thin metal diaphram inside, and this is what sends actual oil pressure value via variable resistance.

Newly Painted! Emerald Green '96 XJ 4x4 4.0 HO 5-spd
3" Lift + 31" Tires / D35 TracLok / NP231
Drilled out Stock Airbox / Gauge Cluster Upgrade
Magnaflow Muffler / High-flo Cat / MSD Coil
BrunoS is offline  
post #3 of 7 Old 01-29-2006, 05:47 PM
jbrem
Registered User
 
jbrem's Avatar
2005 WK 
 
Join Date: Aug 2005
Location: Lake Mills
Posts: 733
Sorry to hijack, but where is the oil pressure sending unit located? (i think near the oil filter? ). My gauge is all messed up, pointing right right 100% of the time, even when the engine is off.
jbrem is offline  
post #4 of 7 Old 01-29-2006, 06:02 PM
Pat96XJ
Registered User
 
Join Date: Jan 2006
Location: Long Island, New York
Posts: 2
I've got a 96 xj with gauges, not just the light, and my oil pressure sender is the 1 wire version. (I've got the 4.0L) It's located on the passenger side of the engine, about 6" above the oil filter, and towards the front of the engine.
Pat96XJ is offline  
post #5 of 7 Old 01-29-2006, 10:53 PM Thread Starter
h2rescue
Registered User
 
h2rescue's Avatar
 
Join Date: Nov 2005
Location: Nicholson, PA
Posts: 190
jbrem, thats what mine is doing. hmm. 1 says 2 wire the other has 1 wire. i suppose ill have to pop the damn hood and look
h2rescue is offline  
post #6 of 7 Old 01-30-2006, 05:19 AM
JoBo
Registered User
 
Join Date: Jul 2004
Location: Columbus, Ohio, USA
Posts: 1,430
Quote:
Originally Posted by h2rescue
jbrem, thats what mine is doing. hmm. 1 says 2 wire the other has 1 wire. i suppose ill have to pop the damn hood and look
That's the best way As for the temp guage sensor if you've got one on the left rear of the cylinder head then that's it. But as I recall my 96 only had the one on the thermostat housing

JoBo
Columbus, Ohio USA
2006 KJ CRD Atlantic Blue Pearl Coat Limited
2000 Cherokee Classic with factory 16" wheels
JoBo is offline  
post #7 of 7 Old 01-31-2006, 09:23 PM Thread Starter
h2rescue
Registered User
 
h2rescue's Avatar
 
Join Date: Nov 2005
Location: Nicholson, PA
Posts: 190
jobo your right there are 2 on the 96 the one i need to change is on the head, except the valve cover is in the way, and it looks like someone tried to get at it cause the brass is folded over and stripped, oh well i wanted to change the valve cover gasket anyway
h2rescue is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Temp Sending unit? XJKyle1995 XJ Cherokee Technical Forum 9 05-28-2011 12:59 AM
Oil Temp and Pressure Sending Unit Location Magus2727 XJ Cherokee Technical Forum 0 03-10-2009 08:39 AM
new engine temp sending unit jeeptorino68 XJ Cherokee Technical Forum 4 03-02-2009 05:58 PM
Temp sending unit failing? PhatJeeps XJ Cherokee Technical Forum 1 10-16-2006 06:49 PM
Where's my Temp Sending Unit????? joshsg XJ Cherokee Technical Forum 3 06-22-2003 11:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome