Oil Pressure.. Opinions! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 13 Old 09-04-2012, 05:59 AM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
Oil Pressure.. Opinions!

In my 01 XJ, my oil pressure stays up pretty high, whether im idling, or cruising down the road. Usuall is up around 75-80...

I have my oil changed regularly, and i do not beat on my Jeep.

Any ideas why the pressure would be so high? Thanks in advance.

acurrier2012 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 09-04-2012, 07:24 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,169
I'm guessing the oil pressure sending unit located near the oil filter is defective and needs replacement.
cruiser54 is offline  
post #3 of 13 Old 09-04-2012, 07:24 AM
Finallyajeep
Registered User
2000 XJ Cherokee 
 
Join Date: Sep 2008
Location: Philadelphia, PA
Posts: 1,207
x2 same thing happened to mine

Firefighters Jeep Club
Finallyajeep is offline  
post #4 of 13 Old 09-04-2012, 10:12 AM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
Nice, Never though of that. Thanks!
acurrier2012 is offline  
post #5 of 13 Old 09-04-2012, 10:20 AM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
Oil Pressure Switch..... Oil Pressure Sending Unit.

Any differences? Same thing? Never delt with one. Thanks.
acurrier2012 is offline  
post #6 of 13 Old 09-04-2012, 10:45 AM
jeepkid03
Winning
 
jeepkid03's Avatar
2000 XJ Cherokee 
 
Join Date: Sep 2008
Location: Storrs
Posts: 6,193
The switch is for the gauge cluster that has just the oil light. The sending unit is for the cluster that has an oil pressure gauge. You want the sending unit. Also remember that some sensors from the auto parts stores are cheaply made and bad right out of the box. I've had good luck with RockAuto.com as well as dealership sensors.
jeepkid03 is offline  
post #7 of 13 Old 09-04-2012, 11:46 AM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
Ill order one of RockAuto.com. Thanks for the advice man!
acurrier2012 is offline  
post #8 of 13 Old 09-07-2012, 05:15 AM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
This is what i see every morning.... Anybody out there seeing the same thing?
Attached Thumbnails
Oil Pressure.jpg  
acurrier2012 is offline  
post #9 of 13 Old 09-07-2012, 05:17 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,169
Kinda high reading.
cruiser54 is offline  
post #10 of 13 Old 09-07-2012, 05:23 AM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
Thats what i assumed. It does go down after a 5-10 minute ride. Just didnt know if it was something obvious..
acurrier2012 is offline  
post #11 of 13 Old 09-07-2012, 08:29 AM
jeepkid03
Winning
 
jeepkid03's Avatar
2000 XJ Cherokee 
 
Join Date: Sep 2008
Location: Storrs
Posts: 6,193
Did you replace the sensor? Its a common failure.

If you replace the sensor and still have problems I'd suspect the gauge is bad. Check with a mechanical oil pressure gauge first to verify your pressure. They are easily rented from autoparts stores and screw into the fitting that the sensor goes in on the block.
jeepkid03 is offline  
post #12 of 13 Old 09-07-2012, 08:41 AM
Marconis
Registered User
2000 XJ Cherokee 
 
Join Date: Jun 2008
Location: Queens
Posts: 339
Same thing has been happening to me for a few months, but I haven't done anything about it. When I start my XJ, it goes straight to 80. When driving, it stays at 80. Sometimes when I idle, it goes to a little above 40 (where it used to always be most of the time), and then shoots right back up to 80 when barely hitting the gas. I'm guessing it's the same problem as you.
Marconis is offline  
post #13 of 13 Old 09-07-2012, 12:54 PM Thread Starter
acurrier2012
Registered User
2001 XJ Cherokee 
 
Join Date: Jul 2012
Location: Machias
Posts: 80
I ordered a new sending unit, but it hasnt came yet. As you stated several times above, thats probably the issue. Just seeing what anybody else has done. Part should be here this afternoon/Monday.
acurrier2012 is offline  
Reply

Tags
cherokee , oil , pressure

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Need Opinions!!! Please give me your opinions!! bmxer0122 XJ/MJ Cherokee Non-Technical Forum 5 05-05-2011 06:29 AM
ac pressure cycling and high pressure cutout NorbertSTL XJ Cherokee Technical Forum 8 08-11-2010 10:33 AM
Low Oil Pressure *Not Sending Unit* need opinions please... MB_01XJ XJ Cherokee Technical Forum 16 12-08-2008 08:27 AM
New & need some opinions.. trailrunnerx XJ Cherokee Technical Forum 2 03-02-2004 09:58 PM
Need some opinions b(k)ill94xj XJ Cherokee Technical Forum 3 03-02-2004 02:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome