Oil Pressure...Guage? Sending Unit? Engine Problem? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Oil Pressure...Guage? Sending Unit? Engine Problem?

Black Friday- Cyber Monday Deals at jeepHutBlack Friday Deals !JcrOffroad Black Friday Sale!

Reply
Unread 03-25-2011, 08:14 AM   #1
XtrailratedJ
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2008
Location: Tampa, FL
Posts: 952
Oil Pressure...Guage? Sending Unit? Engine Problem?



So I notice this when I got to work this morning. Oil pressure has always been between 40 and 60. Maybe a little higher under hard acceleration. I do know I need an oil change, but it has only been about 5000 miles. I am usually really good about doing one about every 3000-4000 miles. Anyways, I'm thinking this might just be a faulty guage. When I turn the engine off, all the other guages zero out. The oil guage stays just like this.

Any Ideas?


Thanks in advance,

-X

__________________
96 XJ 4.0L/AX15/NP231/AUSSIE'D D30/C8.25/4.5" RE LIFT/33'S/BUMPERS, SLIDERS, ETC...
"I pitty the fool who lists D30's and 31's, then tries to talk **** on PBB":

Originally Posted by Durt_Diver:
Those pics might be a little too flexy for this thread. You don't happen to have any pics of your friends xj on a curb by chance?
XtrailratedJ is offline   Reply With Quote Quick reply to this message
Unread 03-25-2011, 08:19 AM   #2
little_Jeep
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2006
Location: Louisville, KY
Posts: 5,947
Check your fluid levels.... then disconnect the wire at the sending unit, you either have a bad sending unit, or you have a short in the wire causing it to ground out, which will peg your guage out.
little_Jeep is offline   Reply With Quote Quick reply to this message
Unread 03-25-2011, 08:35 AM   #3
XtrailratedJ
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2008
Location: Tampa, FL
Posts: 952
Will check fluids at lunchtime. But I do know that contrary to normal XJ functioning, mine loses ZERO oil between oil changes, No spots on the driveway.

I just found it strange the the needle remained pegged after the engine was shut off.
__________________
96 XJ 4.0L/AX15/NP231/AUSSIE'D D30/C8.25/4.5" RE LIFT/33'S/BUMPERS, SLIDERS, ETC...
"I pitty the fool who lists D30's and 31's, then tries to talk **** on PBB":

Originally Posted by Durt_Diver:
Those pics might be a little too flexy for this thread. You don't happen to have any pics of your friends xj on a curb by chance?
XtrailratedJ is offline   Reply With Quote Quick reply to this message
Unread 03-25-2011, 08:37 AM   #4
Jeff88
Web Wheeler
1988 YJ Wrangler 
 
Join Date: Apr 2008
Posts: 1,729
That's a bad sending unit!

easy to fix!
Jeff88 is offline   Reply With Quote Quick reply to this message
Unread 03-25-2011, 09:05 AM   #5
XtrailratedJ
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2008
Location: Tampa, FL
Posts: 952
Quote:
Originally Posted by Jeff88 View Post
That's a bad sending unit!

easy to fix!
Thanks Jeff...

Did a little more research and found others with the same symptom which was resolved with a new sending unit.



I wish more people would be alot more specific in their thread titles. It makes it really hard to find what you are looking for when searching when the title is extremely vague or generic. This causes others to start new threads about issues that have already been beaten to death. Which causes other to get pissed about people not searching.



To Do List for Tomorrow:

1- Replace Oil Pressure Sending Unit

2- Oil Change w/ Larger Oil Filter

3- Replace Belts

4- Clean Throttle Body
__________________
96 XJ 4.0L/AX15/NP231/AUSSIE'D D30/C8.25/4.5" RE LIFT/33'S/BUMPERS, SLIDERS, ETC...
"I pitty the fool who lists D30's and 31's, then tries to talk **** on PBB":

Originally Posted by Durt_Diver:
Those pics might be a little too flexy for this thread. You don't happen to have any pics of your friends xj on a curb by chance?
XtrailratedJ is offline   Reply With Quote Quick reply to this message
Unread 03-25-2011, 09:10 AM   #6
CrawlingForward
Rookies Happen.
 
CrawlingForward's Avatar
1995 YJ Wrangler 
 
Join Date: Nov 2008
Location: Brazoria, Texas
Posts: 2,325
Beware, a lot of people, myself included, often have OPSUs that are bad out of the box, so if it doesn't work don't forget it could still be the sending unit.
__________________
My Other Jeep Is A Jeep - Crawlingforward's Jeep-Related Adventures

95 YJ, Rio Grande - The Wannabe Sleeper Wheeler
2010 JKU, Islander Edition - The Burly Stock Overlander

- North Shore Jeep Club -
Build/Wheel/Break/Educate/Upgrade/Repeat
CrawlingForward is offline   Reply With Quote Quick reply to this message
Unread 03-25-2011, 09:23 AM   #7
XtrailratedJ
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2008
Location: Tampa, FL
Posts: 952
Quote:
Originally Posted by CrawlingForward View Post
Beware, a lot of people, myself included, often have OPSUs that are bad out of the box, so if it doesn't work don't forget it could still be the sending unit.
I did notice quite a few others having this problem. Is this a quality control issue? I don't understand why so many new units would be faulty from the manufacturer.
__________________
96 XJ 4.0L/AX15/NP231/AUSSIE'D D30/C8.25/4.5" RE LIFT/33'S/BUMPERS, SLIDERS, ETC...
"I pitty the fool who lists D30's and 31's, then tries to talk **** on PBB":

Originally Posted by Durt_Diver:
Those pics might be a little too flexy for this thread. You don't happen to have any pics of your friends xj on a curb by chance?
XtrailratedJ is offline   Reply With Quote Quick reply to this message
Reply

Tags
guage , oil , pressure , sending unit

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.