Oil Pressure Gauge reads high on 02 Grand Cherokee - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Oil Pressure Gauge reads high on 02 Grand Cherokee

Spartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREEANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete Gear Installs at CCOR Special

Reply
Unread 12-01-2009, 03:40 PM   #1
docmarvy
Registered User
2002 WJ 
 
Join Date: Apr 2008
Location: Austin, TX
Posts: 3
Oil Pressure Gauge reads high on 02 Grand Cherokee

Hey Everybody!

I'm having some weirdness with my 02 Grand Cherokee V6.

The oil pressure gauge is running high. Like over the top on cold starts and then it eases down after 10-20 minutes of driving, although it still reads in the high-to-very-high area. It's not running any differently, but it's starting to shake my confidence that it's going to break down when I need it most (as seems to be the only time it breaks down).

I recently had the fuel pump replaced, and this didn't happen before that. Although I don't know that they're related. Just saying.

Some other forums say that the switches on these are bad and can give any type of a false readout from too high to dead-low.

I'm just wondering if this is A) A common thing or B) how much I'm looking at for replacement cost. Just a ballpark. I've already put almost $3500 in this Jeep this year alone. And I'm starting to wonder if the cost/value proposition on it is falling in favor of ditching it.

Any help/suggestions would be greatly appreciated.

docmarvy is offline   Reply With Quote Quick reply to this message
Unread 12-01-2009, 07:47 PM   #2
BrunoS
Registered User
 
Join Date: Aug 2004
Location: South Bay Los Angeles, CA
Posts: 2,534
common problem.

new ones are 20-50$ depending on year.

they tend to go bad around 80k and then around every 50-60k after that, worse in normally hot climate areas.

barring weird noises from crankshaft/engine area, and normal driving/no hot or overheating problems; just a bad pressure sending unit.
__________________
Newly Painted! Emerald Green '96 XJ 4x4 4.0 HO 5-spd
3" Lift + 31" Tires / D35 TracLok / NP231
Drilled out Stock Airbox / Gauge Cluster Upgrade
Magnaflow Muffler / High-flo Cat / MSD Coil
BrunoS is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.