OBD2 - Second Opinion - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 12-05-2013, 02:10 PM Thread Starter
mcbeth059
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2010
Location: Uxbridge, Ontario
Posts: 23
OBD2 - Second Opinion

My XJ decided to go for a little walk in the water and ended up getting stuck pretty deep.

Now that it's all dried out and I have time to work on it again, I noticed I had a CEL. No big deal I thought, I'll just plug in my code reader and see what's up.
Nope. Not going to happen. The OBD2 plug is corroded so much that the wires have become detached from the connecter itself. I don't have and great pictures, I'll try again tonight to see what I can get.

Here's a link to the thread I had up from when it was in the water.
http://www.jeepforum.com/forum/f177/...02/index2.html

Should I try to salvage the current OBD2 port and make it work? Cut it out and install a new one? Any other options?

Thanks

mcbeth059 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-05-2013, 03:11 PM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,437
Quote:
Originally Posted by mcbeth059 View Post
My XJ decided to go for a little walk in the water and ended up getting stuck pretty deep.

Now that it's all dried out and I have time to work on it again, I noticed I had a CEL. No big deal I thought, I'll just plug in my code reader and see what's up.
Nope. Not going to happen. The OBD2 plug is corroded so much that the wires have become detached from the connecter itself. I don't have and great pictures, I'll try again tonight to see what I can get.

Here's a link to the thread I had up from when it was in the water.
http://www.jeepforum.com/forum/f177/...02/index2.html

Should I try to salvage the current OBD2 port and make it work? Cut it out and install a new one? Any other options?

Thanks
Is the Data Link Connector all ate up a product of takng a swim or do you think its been working at it for awhile.

I would be concerned about other connectors under the dash as well, and the Junction Block in the passenger footwell. Check the JB.

Anyway, replace the DLC.
CCKen is online now  
post #3 of 3 Old 12-05-2013, 03:15 PM Thread Starter
mcbeth059
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2010
Location: Uxbridge, Ontario
Posts: 23
Quote:
Originally Posted by CCKen View Post
Is the Data Link Connector all ate up a product of takng a swim or do you think its been working at it for awhile.

I would be concerned about other connectors under the dash as well, and the Junction Block in the passenger footwell. Check the JB.

Anyway, replace the DLC.
I'm almost positive it's just from its water sports.
I have already checked/replaced any connectors that I could. And I haven't noticed any other corrosion on any other connectors.
mcbeth059 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome