OBD-II Port won't communicate - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > OBD-II Port won't communicate

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 02-05-2010, 01:26 PM   #1
CV8Mate
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2008
Location: Newark, DE
Posts: 11
OBD-II Port won't communicate

I recently went to get an inspection and I ended up failing due to the fact that my OBD-II Port will not communicate. I then took the dash apart to investigate and learned that the previous owner removed the check engine light. I replaced it and now the light stays on. The jeep has been running well. I have had a couple of rare instances where the car has hesitated a little when it's cold.

While doing a little searching I saw something about crank positioning sensors not allowing the OBD-II port to be read, but I'm not having any of the other symptoms.

CV8Mate is offline   Reply With Quote
Unread 02-05-2010, 01:35 PM   #2
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,415
Quote:
Originally Posted by CV8Mate View Post
... the previous owner removed the check engine light. I replaced it and now the light stays on.
CEL light on is a symptom. Download the CEL codes and fix the problem(s) the codes refer to.
__________________
.

According to the National Shooting Sports Foundation, AR-15 sporting rifles account for nearly 20% of all U.S. firearms sales.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problem; Government is the problem.
CJ7-Tim is offline   Reply With Quote
Unread 02-05-2010, 02:18 PM   #3
jdearmitt
Member
2001 XJ Cherokee 
 
Join Date: Dec 2008
Location: Huntingdon, PA
Posts: 260
He can't read the codes because the scan tool won't connect to the vehicle..
__________________
'01 Black Limited-Build in Process
'96 Green Sport-Totaled but Bought Back
jdearmitt is offline   Reply With Quote
Unread 02-05-2010, 02:39 PM   #4
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,415
On a 1996 can't you use the key on-off-on procedure to get the CEL light to display trouble codes ?

OBD-II ports not communicating with a code scanner when caused by the CPS is because the CPS has failed. If the CPS is failed, the engine will not run.

Try another brand or model of code scanner. Try a different Emissions testing station.
__________________
.

According to the National Shooting Sports Foundation, AR-15 sporting rifles account for nearly 20% of all U.S. firearms sales.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problem; Government is the problem.
CJ7-Tim is offline   Reply With Quote
Unread 02-05-2010, 05:30 PM   #5
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,414
Quote:
Originally Posted by CJ7-Tim View Post
On a 1996 can't you use the key on-off-on procedure to get the CEL light to display trouble codes ?
I think it should work on a 96.

Here is a link to the key-on, key-off procedure. Worth a try. You need to get to those codes!

Computer codes
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is online now   Reply With Quote
Unread 02-16-2010, 05:47 AM   #6
CV8Mate
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2008
Location: Newark, DE
Posts: 11
I still can't pull the code. The OBD-2 plug wouldn't read at the Chrysler dealership either. They had no clue why and wanted 150 bucks to "investigate". I also tried to do the key on-off-on procedure and it didn't work.
CV8Mate is offline   Reply With Quote
Unread 02-16-2010, 07:55 AM   #7
theglowingbus
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2008
Location: , Colorado
Posts: 149
Check your ground wire that is connected to where the oil dipstick tube is bolted to. It should be a ground coming out of a wiring harness. This was the ground for my obdII connector on my 97 it should probably be the same for your 96. I had the same symptoms as you also.
theglowingbus is offline   Reply With Quote
Unread 02-16-2010, 09:18 AM   #8
CV8Mate
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2008
Location: Newark, DE
Posts: 11
Thanks, I'm going to check this out later today. Did you have any other issues solved by this? I am having an issue with the headlight going out and the turn signal arrows and high beam dash indicators go on. I am trying to figure out if this is a related issue or separate problem.

Quote:
Originally Posted by theglowingbus View Post
Check your ground wire that is connected to where the oil dipstick tube is bolted to. It should be a ground coming out of a wiring harness. This was the ground for my obdII connector on my 97 it should probably be the same for your 96. I had the same symptoms as you also.
CV8Mate is offline   Reply With Quote
Unread 02-16-2010, 09:55 AM   #9
theglowingbus
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2008
Location: , Colorado
Posts: 149
I don't remember a problem with headlights or turn signals although i also don't remember trying them in that period of time, but i do remember that every time i tried to plug in a scanner the airbag lights would go on and some other dash lights and sometimes the tach wouldn't work either.
theglowingbus is offline   Reply With Quote
Unread 02-16-2010, 10:44 AM   #10
CV8Mate
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2008
Location: Newark, DE
Posts: 11
I just check the ground wires attached to the dipstick. They are all intact and don't appear corroded.
CV8Mate is offline   Reply With Quote
Unread 02-16-2010, 10:51 AM   #11
PhilipJ
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2004
Location: Oak Harbor, WA
Posts: 1,417
I can't pull any codes from my XJ either. The scanner will initialize the connection okay but will freeze halfway into pulling the codes. I know the scanner works because it's worked fine on friends' vehicles.

I get a CEL maybe every other month but it only stays on for a day and then goes away again.
PhilipJ is offline   Reply With Quote
Unread 02-16-2010, 12:53 PM   #12
CV8Mate
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2008
Location: Newark, DE
Posts: 11
Does the car run fine while the check engine light is on?

Quote:
Originally Posted by PhilipJ View Post
I can't pull any codes from my XJ either. The scanner will initialize the connection okay but will freeze halfway into pulling the codes. I know the scanner works because it's worked fine on friends' vehicles.

I get a CEL maybe every other month but it only stays on for a day and then goes away again.
CV8Mate is offline   Reply With Quote
Unread 02-16-2010, 01:16 PM   #13
PhilipJ
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2004
Location: Oak Harbor, WA
Posts: 1,417
Yep, runs like a champ. It's probably just from me not cranking the gas cap back down enough clicks.
PhilipJ is offline   Reply With Quote
Unread 02-16-2010, 02:56 PM   #14
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,914
Friend of mine at the dealership said to disconnect CPS before hooking up scanner/DRB if you are experiencing a lack of communication problem.
cruiser54 is offline   Reply With Quote
Unread 02-16-2010, 03:07 PM   #15
CV8Mate
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2008
Location: Newark, DE
Posts: 11
Thanks, I will give that a try as soon as I get home.

Quote:
Originally Posted by cruiser54 View Post
Friend of mine at the dealership said to disconnect CPS before hooking up scanner/DRB if you are experiencing a lack of communication problem.
CV8Mate is offline   Reply With Quote
Reply

Tags
cel , obd-2 , obd-ii
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.