OBD-II Port won't communicate - Page 2 - JeepForum.com

LinkBack Thread Tools
post #16 of 18 Old 03-15-2010, 05:15 AM
Registered User
Join Date: Mar 2010
Location: Australia
Posts: 4
I am having a similar problem with my 1998 Jeep Wrangler. I lost the keys and took the car to the dealership to have the key coded, only to be told that their computer won't communicate with the computer in the car. I have also recently had a problem with the headlights of the car not turning on, I had this fixed by an auto electrician. Maybe this has caused a fault with connecting with the computer?

They want to charge me $300 for the key plus $110 for every hour that it takes to find the problem.
Any ideas?

GreenForest is offline  
Sponsored Links
post #17 of 18 Old 03-15-2010, 05:57 AM
Web Wheeler
cruiser54's Avatar
1990 MJ Comanche 
Join Date: Oct 2009
Location: Prescott
Posts: 11,191
I would try disconnecting the CPS regardless of whether the vehicle runs . My tech friend at the dealership said it doesn't matter. Just disconnect it, then attempt to communicate. The CPS doesn't have to be bad to cause the miscommunication problem. As for those of you mentioning the frounds at the dipstick tube stud, and anywhere else for that matter, you can't just gander at them and try to wiggle them. You must get out the wrenches/sockets, remove the fasteners, clean the harness ends til shiny, and then remove any paint/corrosion on the mounting stud/surfaces. Then reinstall everything back bright and shiny.
cruiser54 is offline  
post #18 of 18 Old 03-18-2010, 05:47 PM
Registered User
1989 YJ Wrangler 
Join Date: Nov 2008
Location: Georgia
Posts: 1,339
The ground for the headlights is on the fender well near the computer on the firewall side. You should try checking those grounds.
Where is the OBDII port located? Isn't it right under the dash a little to the left of the steering column?

Herc.Custom Green paint. RC 4". 5 Goodyear 33X12.5 MT/R w/Kev. Cragar V5's. Corbeau Moab seats. Optima Yellow.XRC8 Comp Winch. XJ 4.0/AX15
WTT: 4" springs for 6"
WTS: 4.2 parts. Fuel lines, pump, block, head, accessories, just ask
green89yj is offline  

cel , obd-2 , obd-ii

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
A/C, which port is low pressure Ex-Jay XJ Cherokee Technical Forum 3 04-30-2013 07:20 PM
OBD II does not communicate spdnjoe XJ Cherokee Technical Forum 6 11-04-2009 03:42 PM
port and polish? jackdup XJ Cherokee Technical Forum 6 09-30-2008 06:18 PM
NYC port authority 9/11 XJ tozier9 XJ Cherokee Technical Forum 9 05-29-2007 09:47 AM
Port match or not? Steve88XJ XJ Cherokee Technical Forum 6 02-18-2007 11:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome