No Spark issue still cranks...tunnel vision and stumped. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > No Spark issue still cranks...tunnel vision and stumped.

RIGID LED Light Blowout Sale - All Sizes, All Series, all Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineJeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 09-03-2011, 02:20 PM   #1
Hahnz
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2011
Location: Chicago, IL
Posts: 2
No Spark issue still cranks...tunnel vision and stumped.

So here it is..1996 xj 4.0 with 240,000 and was running strong until recently.
Had it running, threw it in reverse and it died out with no stumbling just quit.
Jumped to conclusion and replaced cps and no luck starting again. Found out it was fuel pump and replaced and now its getting gas again but now there is no spark. Checked coil and that checks out good on the ohm meter. Pulled distributor cap and rotor is spinning as well. Swapped asd relay and still no luck. Next thing to do is light test all the fuses and tomorrow I'm going to try and throw a scan tool on it.

When I bought my new cps it was the right sensor but the wrong plug. So I spliced the plug with the correct one and installed with still no spark and I put the old one in just for kicks and still the same symptoms.

Any insight would be greatly appreciated!

Hahnz is offline   Reply With Quote Quick reply to this message
Unread 09-03-2011, 02:23 PM   #2
spdcat01TJ
Registered User
2001 TJ Wrangler 
 
Join Date: May 2008
Location: Tyler, TX
Posts: 892
I'm having the exact same issue! I've replaced the CPS, and swapped the ASD relay as well. No fire coming from the coil. Sporadic voltage to the coil. I'm gonna try replacing the coil. (I have a spare)
The distributor shaft has a lot of play in it, and I'm wondering if the Camshaft position sensor in the distributor may be bad and causing the PCM to not send a signal to the ASD to power the coil.
__________________
If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O' Donnell fat!

NRA Member
'01 TJ Sahara, 3" BB front, 2.25" BB rear, 1.25 JKS BL, 1" MML, Skyjacker Hydro shocks,33/12.50x15 BFG TA/KO All Terrains homemade disco's, Hi-Lift, CB, GPS
spdcat01TJ is offline   Reply With Quote Quick reply to this message
Unread 09-03-2011, 02:30 PM   #3
Hahnz
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2011
Location: Chicago, IL
Posts: 2
I'm just boggled that the fuel pump goes out and all of a sudden I have a spark issue...what are the odds???
Hahnz is offline   Reply With Quote Quick reply to this message
Unread 08-04-2012, 01:19 PM   #4
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan, Kentucky
Posts: 168
Ive heard your ignition coil can get a bad ground, I don't exactly know how to fix it though.
87manche17 is offline   Reply With Quote Quick reply to this message
Unread 08-04-2012, 01:41 PM   #5
buildin1XJ
Web Wheeler
1999 XJ Cherokee 
 
Join Date: Oct 2011
Location: Knoxville, Tn.
Posts: 1,581
Do your reverse lights come on when you shift it into reverse? have you tried to start it in neutral,or jiggled your shifter around to se if it will start.If any of this is occurring you may neeed to either clean or replace your Neutral Safety switch NSS
buildin1XJ is offline   Reply With Quote Quick reply to this message
Unread 08-05-2012, 11:19 AM   #6
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan, Kentucky
Posts: 168
Yes, my NSS is fine I believe its my ignition control module, because I have power going to the module but none coming from the coil.
87manche17 is offline   Reply With Quote Quick reply to this message
Reply

Tags
no spark

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.