No Lights ... High Beam Indicator On - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 05-13-2013, 03:10 PM Thread Starter
KPBJeep
Registered User
 
Join Date: May 2013
Location: Woburn
Posts: 1
No Lights ... High Beam Indicator On

I have a 2000 Jeep Cherokee Sport with a 4.0 Engine. The front headlights went out and when you turn on the lights, the High Beam Indicator comes on.

Any Ideas????

KPBJeep is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-13-2013, 07:29 PM
CJ7-Tim
Real Jeeps have dents
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis
Posts: 25,101
Use your $8-16 Volts/Ohms Multi-Meter you purchased at the local hardware store, home improvement store, or WalMart type store to test for 12 volts and ground at the headlight plugs. Inspect the headlight relays and test for 12 volts. Test for 12 volts at the headlight switch. Consider that the headlight switch or the turn signal multi-function switch may have failed. Look for corroded/damaged/melted wires and wire plugs.

.

A recent Gallup public opinion poll shows the NRA, at 58% approval, has a higher approval rating than either Hillary Clinton or Barack Obama.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ...

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline  
Reply

Tags
lights

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome