new leafs new squeak -

LinkBack Thread Tools
post #1 of 3 Old 10-13-2009, 06:50 PM Thread Starter
Web Wheeler
2010 JK Wrangler 
Join Date: Mar 2009
Location: Colorado Springs
Posts: 2,046
new leafs new squeak

hey guys just put in my new HD leafs ( will get before and after pics soon) but after driving it i am getting a squeak from the rear would the bushings be making the noise? they are polyurethane? it sounds like it is coming from more middle so i dont think its the shocks what is everyones thoughts

COLOUXJ is offline  
Sponsored Links
post #2 of 3 Old 10-13-2009, 07:24 PM
Registered User
1997 XJ Cherokee 
Join Date: Aug 2005
Location: High Point, North Carolina
Posts: 1,939
Mine did the same thing when I got mine. go buy some spray white lithium grease and just spray the heck out of them. They will still squeak a bit but after a while it will go away. I haven't sprayed mine in months and they are as quiet as can be.

97 XJ 4.0 Auto D30/29 Sp. 8.25. Yukon 4.10's
4.5" IRO Long Arm Kit - 33x12.50x15's
HD Offroad Engineering Shackle Relocation Brackets
Bilstein 5100's - Magnaflow Exhaust.
Cherokeekid88 is offline  
post #3 of 3 Old 10-13-2009, 08:55 PM Thread Starter
Web Wheeler
2010 JK Wrangler 
Join Date: Mar 2009
Location: Colorado Springs
Posts: 2,046
alright thats what i was thinking just wanted to see if anyone else had the issue if it stayed like that for the rest of the life of the springs i would not be a happy camper
COLOUXJ is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
“Squeak-Squeak-Squeak” coming from the front end itzaxj92 XJ Cherokee Technical Forum 14 03-27-2009 02:04 PM
HD Factory Leafs or 3.5 Pro Comp Leafs?? 94HOCHEROKEE XJ Cherokee Technical Forum 6 01-29-2009 02:38 AM
S10 Blazer Leafs have metal 'spacers' in between leafs. WHY? akxj01 XJ Cherokee Technical Forum 1 01-17-2009 05:01 PM
RE 5.5 leafs with leafs removed rockrawler4.0 MJ Comanche Technical Forum 0 10-29-2008 04:09 PM
Rusty's leafs replaced with bigoffroad leafs xjj33p3r XJ Cherokee Technical Forum 13 06-13-2005 10:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome