Need help with cherokee xj - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 05-16-2013, 07:36 PM Thread Starter
newbjeepowner
Registered User
1999 XJ Cherokee 
 
Join Date: May 2013
Location: Rochester
Posts: 7
Need help with cherokee xj


I have a 99 jeep cherokee sport with the 4.0L engine. i just recently noticed a light grinding noise only when driving above 15mph, then below or even sometimes when idling especially when gaining speed there is a ticking noise. my rear end is sagging and my leafs are just at the point of inverting (i am working on this) just in case that could have something to do with it, but the most unusual thing is that i can feel all of this in shifter for the 4wd but not in the e-brake handle or the regular shifter.

newbjeepowner is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 05-17-2013, 09:20 AM
pokeyxj
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Albuquerque
Posts: 153
Drain t-case and look in drain hole at chain, could be stretched and rubbing the case. That could be both grinding and ticking noises.

2000 XJ Limited, 4.5 Rusty's All spring lift; 265/75/16 BFG KM2's; 4.0, aw4, 242.
2001 XJ Sport, 4.5 Rusty's lift, 32x1150x15 Hankook Dynapro MT's. 4.0, aw4, 231, 8.25 rear with power trax locker.
08 f 150 2.5 lift, 33's, arb.
pokeyxj is offline  
post #3 of 8 Old 05-23-2013, 06:44 PM Thread Starter
newbjeepowner
Registered User
1999 XJ Cherokee 
 
Join Date: May 2013
Location: Rochester
Posts: 7
thanks think only thing that i have not replaced oil in. so i will check, i noticed while idle however more of a rattling than ticking like somethings loose.
newbjeepowner is offline  
post #4 of 8 Old 05-23-2013, 06:57 PM
cory4um
Registered User
1999 XJ Cherokee 
 
Join Date: May 2009
Location: Skook
Posts: 609
The transfer case shift linkage makes a lot of noise if the bushings go bad. Only really Noticeable when idling. Wiggling the shifter will make it stop.t.confirming your linkage needs a rebuild.
That should take care of one of your noises
cory4um is offline  
post #5 of 8 Old 05-24-2013, 09:21 PM
holysirsalad
Registered User
1999 XJ Cherokee 
 
Join Date: Dec 2011
Location: Kingston
Posts: 306
I doubt his transfer case chain is going to be doing much when he's idling.

Have you checked your flexplate bolts? They have a habit of backing out and making a variety of noises from what you describe to a knocking.
holysirsalad is offline  
post #6 of 8 Old 08-22-2013, 04:02 PM Thread Starter
newbjeepowner
Registered User
1999 XJ Cherokee 
 
Join Date: May 2013
Location: Rochester
Posts: 7
thanks everyone but it seemed to have stopped. i have a more annoying problem now however. i got a p0455 code and one for O2 sensor. had to repair wire to O2 sensor replaced line to evap reservior (had holes where rubbed on frame) and found hose broken off charcoal canister. still had evap code pop back up. but also notice that my A/C condenser is contantly running producing condesate when it is not on? is this related or another isse entirely. and how do i test the purge valve pls. and yes apparantley the wires and hose broke from off roading is too fun not to. but the more fun the more the damage lol.
newbjeepowner is offline  
post #7 of 8 Old 08-22-2013, 06:28 PM
bigbill888
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: michigan
Posts: 969
Quote:
Originally Posted by newbjeepowner View Post
my A/C condenser is contantly running producing condesate when it is not on
Is heater control set on "defrost"? If so, A/C compressor is on.

96 ZJ Laredo, 4.0, 242, 230K
95 ZJ Limited, 4.0, 242, 140K
98 XJ Sport, 4.0, 231, 140K
All work well
bigbill888 is offline  
post #8 of 8 Old 08-28-2013, 06:51 PM Thread Starter
newbjeepowner
Registered User
1999 XJ Cherokee 
 
Join Date: May 2013
Location: Rochester
Posts: 7
even if off, as long as the hot cool setting is anywhere from half way to cool compressor full on consistantly running not even just cutting in and out i don't get it but i don't want hot air seeping through vents while its summer... causes engine to over heat if sitting too long also.
newbjeepowner is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome