JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   XJ Cherokee Technical Forum (http://www.jeepforum.com/forum/f11/)
-   -   Is my cherokee running warm? (http://www.jeepforum.com/forum/f11/my-cherokee-running-warm-1542251/)

Jeeper_YJ 06-27-2013 08:36 PM

Is my cherokee running warm?
 
Today was 100* outside. No stop and go. Around town. Ran at the notch above 210* on gauge (220*?). I did have buddy shoot a heat temp laser and the gauge is accurate. I have replaced last month:

Fan clutch (heavy duty)
Aluminum 2 row radiator
New hoses
New water pump
180* t-stat
coolant sensor
Radiator cap
Synthetic oil change

I did also just did a comp cam and performance head swap along with a performance header. Do hood vents actually work? Anyone done it and can verify?

Craig00XJ 06-27-2013 10:39 PM

I read over and over on this site that you should use a 195 degree thermostat. Maybe try that first? Certainly a cheap fix if it turns out to be the cause.

Jeeper_YJ 06-27-2013 10:41 PM

Quote:

Originally Posted by Craig00XJ (Post 15616435)
I read over and over on this site that you should use a 195 degree thermostat. Maybe try that first? Certainly a cheap fix if it turns out to be the cause.

Ran both, same result. :(

Are you saying it is running hot?

Craig00XJ 06-27-2013 10:43 PM

Yeah, it should be around the 210 mark

Jeeper_YJ 06-27-2013 10:46 PM

Quote:

Originally Posted by Craig00XJ (Post 15616451)
Yeah, it should be around the 210 mark

100* outside, and A/C on? Ok.

What else can I replace? I'm at a loss.

Puck81 06-27-2013 10:55 PM

That is where my XJ likes to run in our heat. You are good bud. And yes hood vents are a good thing out here too. Btw what side of town you on?

Jeeper_YJ 06-27-2013 10:57 PM

Henderson. :)

The notch passed 210* is 215 or 225*?

Puck81 06-27-2013 11:14 PM

It's ~220ish. The factory electric fan comes on at about 209 and shuts off at about 220, and that is about the mark mine shuts down. I live close to Henderson, off of Windmill pkwy and the 215. You should visit the Vegas thread some time.

Jeeper_YJ 06-27-2013 11:17 PM

You mean on at 218 and off at 209? :) Is this normal running at 220* or so you think the radiator I put in is maybe clogged or bad?

Jeeper_YJ 06-27-2013 11:26 PM

Is it possible the new radiator is clogged or bad?

Puck81 06-27-2013 11:44 PM

Quote:

Originally Posted by Jeeper_YJ (Post 15616542)
You mean on at 218 and off at 209? :) Is this normal running at 220* or so you think the radiator I put in is maybe clogged or bad?

There you go, sorry i am a tad tired.

Puck81 06-27-2013 11:45 PM

Quote:

Originally Posted by Jeeper_YJ (Post 15616573)
Is it possible the new radiator is clogged or bad?

I dont think so. XJs will never run cooler then 210-220. Its how our motors are tuned to run.

sAe23 06-27-2013 11:50 PM

My 95 runs right around 210* (A/C ON) on a normal SoCal day.
When it gets above 95 - 100 degrees, the gauge gets real close to the 3rd mark, which I guesstimate is 235*.
Turning the A/C off and/or turning on the heater for a few minutes usually brings it back down.

Yours sounds ...typical... :D

TheBoogieman 06-28-2013 06:08 AM

220 is fine and normal for hot days.Mine runs the same.

tim111762 06-28-2013 07:07 AM

Down here in the Florida heat I run 210-220 range normally


The time now is 12:36 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.