map sensor problems HELP!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > map sensor problems HELP!!!

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank SkidFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 02-11-2011, 05:04 PM   #1
ty1123
Registered User
1988 XJ Cherokee 
 
Join Date: Feb 2011
Location: spanaway, wa
Posts: 6
map sensor problems HELP!!!

ok so i have an 88 xj 4.0 efi, ive been having problems with it running extremely rich for a few months ive gone through everything i could possibly think of and then i replaced the map sensor and it idles WAY better and its not running so rich at an idle but then when i give it a little gas it misses and backfires and a **** ton of black smoke comes out the back. and it only is like that when the map sensor is hooked up...i take the vacuum line out of the throttle body and its back to running rich but it doesnt miss and backfire anymore. im at my wits end on this and its getting very irritating and expensive. any input is greatly appreciated.

__________________
[FONT="Comic Sans MS"][/FONT]
Buckle up...I wanna try something ;)
ty1123 is offline   Reply With Quote
Unread 02-12-2011, 06:14 AM   #2
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,417
Have you verified proper fuel delivery? If not, should do so.

For an 88, you should have 31 psi at idle. Then disconnect the vacuum line leading to the fuel pressure regulator and the pressure should jump to approx. 39 psi. Also be sure that the FPR vacuum line is pulling good vacuum and is not wet with fuel. If that vacuum line has gas in it, replace the regulator.
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline   Reply With Quote
Unread 02-12-2011, 09:30 PM   #3
ty1123
Registered User
1988 XJ Cherokee 
 
Join Date: Feb 2011
Location: spanaway, wa
Posts: 6
OK thank you, i will do that tomorrow and let you know what happens.

appreciate the input.
__________________
[FONT="Comic Sans MS"][/FONT]
Buckle up...I wanna try something ;)
ty1123 is offline   Reply With Quote
Unread 02-13-2011, 03:32 PM   #4
ty1123
Registered User
1988 XJ Cherokee 
 
Join Date: Feb 2011
Location: spanaway, wa
Posts: 6
ok so i put a new FPR on it and a fuel filter as well and it still misses and backfires when i hook up the map sensor. i dont know what else to do
__________________
[FONT="Comic Sans MS"][/FONT]
Buckle up...I wanna try something ;)
ty1123 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.