Losses power after running for a couple of minutes - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Losses power after running for a couple of minutes

Dual Color LED Light Bars White/AmberTJ 5.25" Speaker Adapters - NalinMFGAlloy USA Still Available

Reply
Unread 05-19-2013, 10:31 AM   #1
Dankennedy
Registered User
 
Join Date: May 2013
Location: ELON, North Carolina
Posts: 2
Losses power after running for a couple of minutes

Looking for help. I have a 2000 Grand Cherokee with 4.0 it starts ok after a couple of minutes it losses power. You try to go from a light and it does want to go. I have to push on the gas pedal much harder then normal. It will only run bad for a couple of minutes then run good. I had it in the driveway and got it to do it and at a idle it sounded like it was having a tough time sucking air in so I changed the idle air valve, then throttle position sensor,air & water temp sensors it is not throwing any codes. Any help would be appreciated!

Dankennedy is offline   Reply With Quote
Unread 05-19-2013, 11:14 AM   #2
jeepmike99
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2010
Location: Temecula, California
Posts: 15
I'm having the same problem with my '99 XJ. I'm thinking it's a fuel issue, so I'm looking forward to some answers to your thread.
jeepmike99 is offline   Reply With Quote
Unread 05-19-2013, 11:55 AM   #3
Dankennedy
Registered User
 
Join Date: May 2013
Location: ELON, North Carolina
Posts: 2
I checked fuel pressure it is good 50 PSI, I just checked the map sensor I think it is good. After running for a minute at an idle I can hear the air getting choked going in the motor it will run like that for a minute then run fine
Dankennedy is offline   Reply With Quote
Unread 05-19-2013, 12:17 PM   #4
jeepmike99
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2010
Location: Temecula, California
Posts: 15
I just went out and started it up and let idle for about 5 minutes and it never stalled out. It seems to only have the problem if I start it up and take off within a few minutes. I guess if I just let her do her thing then drive her, she'll be ok. I should know that since I'm married.
jeepmike99 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.