Loose Steering and Sliding - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 03-01-2013, 01:28 PM Thread Starter
ngrubich
Registered User
2000 XJ Cherokee 
 
Join Date: Dec 2009
Location: Charlotte
Posts: 133
Loose Steering and Sliding

My 2000 XJ (3" lift, 31" BFGs; had for several years) has recently started to have a loose steering wheel problem and it feels like I'm almost sliding when going around turns.
I'm getting ready to change out the upper control arms, track bar bushing, and sway bar bushings this weekend as an overhaul project. Is there something else I should look for?

ngrubich is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-01-2013, 02:12 PM
Diamond-x
Registered User
1991 XJ Cherokee 
 
Join Date: Aug 2008
Location: Socal
Posts: 1,212
Sounds like it's in 4WD. Check your T/C linkage.
Diamond-x is offline  
post #3 of 6 Old 03-01-2013, 03:04 PM Thread Starter
ngrubich
Registered User
2000 XJ Cherokee 
 
Join Date: Dec 2009
Location: Charlotte
Posts: 133
I can hear it shifting into 4H and then over into 4L, so I don't think that is the issue (although the linkage bushings are getting kinda old). My t case 4WD switch isn't working, so I'll go grab one from the store so I can figure out if I'm sticking in 4WD and report back.
ngrubich is offline  
post #4 of 6 Old 03-01-2013, 05:06 PM
Diamond-x
Registered User
1991 XJ Cherokee 
 
Join Date: Aug 2008
Location: Socal
Posts: 1,212
If I'm in 4WD and I try a tight turn at low speeds my XJ slides more than it turns.
Diamond-x is offline  
post #5 of 6 Old 03-01-2013, 06:29 PM Thread Starter
ngrubich
Registered User
2000 XJ Cherokee 
 
Join Date: Dec 2009
Location: Charlotte
Posts: 133
I usually get the sliding at higher speeds, like 10-15mph upwards (like turning onto the on-ramp of a highway). At low speeds (in 4WD), my steering wheel jerks back and forth, but I don't really get any sliding, but then again I haven't really tried to notice it.
ngrubich is offline  
post #6 of 6 Old 03-01-2013, 08:50 PM Thread Starter
ngrubich
Registered User
2000 XJ Cherokee 
 
Join Date: Dec 2009
Location: Charlotte
Posts: 133
Update: just replaced the switch on the transfer case and my dash isn't showing that I'm in 4WD; still having the same problem as before (I know the bulb isn't out because the new switch turns the light on on the dash when I move the lever myself).
ngrubich is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome