left turn signal doesn't work if braking - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 12-26-2010, 11:22 PM Thread Starter
jennali
Registered User
2001 XJ Cherokee 
 
Join Date: Dec 2010
Location: Columbus
Posts: 4
left turn signal doesn't work if braking

Hi. I have a 2001 XJ that I bought about two months ago. The problem is that when I am braking before I turn, the left turn signal stops blinking (light on dash stays lit), but as soon as I take my foot off the brake it blinks normally. Just before it did this the left turn signal was blinking quickly like it would if a bulb was out, and the right turn signal works fine. On a side note, my left rear tail light is burnt out (I assume it is since it isn't lighting, although the brake lights are fine), and I have only really had this issue since the weather got colder. Any ideas? I saw some similar threads on here but nothing quite answered my question. Any help is greatly appreciated!

jennali is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-27-2010, 12:36 AM
littlehoov
Registered User
1986 XJ Cherokee 
 
Join Date: May 2009
Location: climax springs, mo
Posts: 261
It sounds like a ground issue...Id pop off the taillamp assembly, look for any poor connections, melted connections, etc.

I believe the ground for the turn signals is underneath the plastic piece on the side of your rear cargo area, theres probably also an adapter plug there worth checking out.

My moms Venture had similar problem which was caused by the ground plug on the plastic taillight connector melting...a common problem in those vans.

1986 Cherokee 2.8 V6, Torqueflight 904 transmission, NP-228 transfer case. 235/75/15 AT tires. Factory tow hooks...thats about it.
littlehoov is offline  
post #3 of 7 Old 12-27-2010, 01:15 AM
Mr_Clickerson
Registered User
1994 XJ Cherokee 
 
Join Date: Aug 2008
Location: KCMO
Posts: 260
Quote:
Originally Posted by littlehoov View Post
It sounds like a ground issue...Id pop off the taillamp assembly, look for any poor connections, melted connections, etc.

I believe the ground for the turn signals is underneath the plastic piece on the side of your rear cargo area, theres probably also an adapter plug there worth checking out.

My moms Venture had similar problem which was caused by the ground plug on the plastic taillight connector melting...a common problem in those vans.
Seconded. Sounds like a bad ground. Had the same issue with my blinkers when my headlights were on. Bad grounds to the parking lamps just below the headlights.

Quote:
Originally Posted by Lamb of God
Whoever appeals to the law against his fellow man is either a fool or a coward; whoever cannot take care of himself without that law is both. For wounded man shall say to his assailant, "if I live, I will kill you- if I die, you are forgiven;" such as the rule of honor.
Mr_Clickerson is offline  
post #4 of 7 Old 12-27-2010, 07:25 AM
xjfever
Web Wheeler
 
xjfever's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2008
Location: north Ga.
Posts: 14,216
I would start with replacing the bulb and see if the issue goes away. Sometimes the bulb will cause the problem, also make sure the socket is clean and rust/dirt free. Then add a small amount of dielectric grease to the socket before putting the new bulb in. If the bulb doesn't fix it then the above posts are correct that it is a ground problem. More often than not the ground issue is within the socket rather than the wiring though.

  1. '95 XJ country edition, 4" coils/3/4" spacers, HD leafs with extra main added in, Ironman adjustable control arms, rough country shackles, aussie locker, JK rubicon shocks, 35" mudder's, soft 8's, cobra cb
  2. Sold'99 WJ limited, 4.7L, 3" IRO lift. Bilstein shocks, JK rubicon wheels, 255/70/17's, carolina driveshaft, IRO adjustable control arms, IRO adjustable A-arm
  3. Sold '00 TJ, 4" lift, rusty's adjustable control arms, skyjacker shocks, rock krawler adj. trac-bar,rugged ridge SYE and RE driveshaft, soft 8's, 35" mud king xt's,XJ HP D30 w/aussie locker, 4:88 yukon gears, hella 500's, rock crusher diff covers
4. 04 Dodge ram 1500 quadcab, yes, it has a hemi.
5. '08 BMW X3, Mods in progress.
xjfever is offline  
post #5 of 7 Old 12-27-2010, 05:06 PM Thread Starter
jennali
Registered User
2001 XJ Cherokee 
 
Join Date: Dec 2010
Location: Columbus
Posts: 4
Thanks for all the advice! It's freezing cold and dark out now and my jeep lives outside but tomorrow I will try to replace the bulb and if it's still messed up I'll look at the grounding...I don't know a ton about cars but I would love to fix this myself and not pay a ridiculous amount of money if it is a relatively simple problem...I'll keep you posted and may ask more questions later! Thanks
jennali is offline  
post #6 of 7 Old 12-27-2010, 05:56 PM Thread Starter
jennali
Registered User
2001 XJ Cherokee 
 
Join Date: Dec 2010
Location: Columbus
Posts: 4
Ok well I tried to post a reply about an hour ago but it is not showing up so I will try again! Thanks for all of the advice first off. It is dark out and freezing cold now and my poor little jeepie lives outside but tomorrow I will try to replace the taillight and see if that helps at all. If not then I will try to look at the grounds. I don't know a ton about cars but I would love to try fix this myself and not spend a ridiculous amount of $ on a relatively simple problem. Also I forgot to mention that I do have a trailer hitch (which I will be removing at some point). Could that be affecting the lights where it is wired in? Also, when i put my hazard lights on, ONLY my left turn signal flashes, my right does not....very bizarre to me. Thanks again and I will probably be back with more questions tomorrow!
jennali is offline  
post #7 of 7 Old 12-27-2010, 06:55 PM
xjfever
Web Wheeler
 
xjfever's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2008
Location: north Ga.
Posts: 14,216
You can fix it yourself with a little help, and there are a ton of folks here who can help you. Just post up your results and if you don't get it fixed right away someone on here will help you through it. The trailer wiring could also be the culprit, but it for sure sounds like a ground problem. Good luck and welcome to the forum.

  1. '95 XJ country edition, 4" coils/3/4" spacers, HD leafs with extra main added in, Ironman adjustable control arms, rough country shackles, aussie locker, JK rubicon shocks, 35" mudder's, soft 8's, cobra cb
  2. Sold'99 WJ limited, 4.7L, 3" IRO lift. Bilstein shocks, JK rubicon wheels, 255/70/17's, carolina driveshaft, IRO adjustable control arms, IRO adjustable A-arm
  3. Sold '00 TJ, 4" lift, rusty's adjustable control arms, skyjacker shocks, rock krawler adj. trac-bar,rugged ridge SYE and RE driveshaft, soft 8's, 35" mud king xt's,XJ HP D30 w/aussie locker, 4:88 yukon gears, hella 500's, rock crusher diff covers
4. 04 Dodge ram 1500 quadcab, yes, it has a hemi.
5. '08 BMW X3, Mods in progress.
xjfever is offline  
Reply

Tags
brake , turn signal , xj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
left rear tails do not work--left signal and left stop do- kenific XJ Cherokee Technical Forum 2 12-06-2008 12:23 PM
Left Turn Signal Going Crazy Redrum8675 XJ Cherokee Technical Forum 7 09-08-2008 02:10 PM
Left turn signal ledfoot02 XJ Cherokee Technical Forum 1 12-25-2007 08:05 AM
Left turn signal wont turn off. paulmatyn XJ Cherokee Technical Forum 13 12-14-2007 11:38 PM
right turn signal faster then the left vswv8 XJ Cherokee Technical Forum 7 10-06-2007 09:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome