Jeep Cherokee XJ - Low idle when it comme warmer - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 07-24-2013, 08:21 AM Thread Starter
cherosport
Registered User
2000 XJ Cherokee 
 
Join Date: Jul 2013
Location: Beloeil
Posts: 5
Jeep Cherokee XJ - Low idle when it comme warmer

Hi,

Hope somebody here will be able to help me, it's my first post on this forum. (Sorry for my bad english)

Cherokee Sport XJ 2000 - 4.0l

My oncle give me this truck after replacing the battery and the alternator. When I start it when it's cold I have no problem, and the Idle is good.

But after running 2 - 3 street corner the idle drop down close to 250 - 300 rpm when I'm at a stop or red light than I have to put it on Neutral and gime some gaz if I don't want the motor to shut off.

I read everywhere and it seem to have many solutions ... but I don't know where to start.

Here's a picture, just for fun !




Last edited by cherosport; 07-24-2013 at 08:47 AM.
cherosport is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-24-2013, 08:31 AM
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington
Posts: 994
When was the last time you changed tour Oxygen Sensors? Is the check engine light on?
That picture is HUGE, taking forever to load

99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
79chiefs is offline  
post #3 of 8 Old 07-24-2013, 08:39 AM Thread Starter
cherosport
Registered User
2000 XJ Cherokee 
 
Join Date: Jul 2013
Location: Beloeil
Posts: 5
Check engine light isn't on. I think O2 sensor have never been changed.

Yeah huge picture but not hosted on forum. Depend of your internet speed.

And if it's the O2, why it run good at cold start and bad when warm ?

Thanks for your reply.
cherosport is offline  
post #4 of 8 Old 07-24-2013, 08:44 AM
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington
Posts: 994
Once the engine get to operating temp the computer starts reading from the sensors to help emissions.

99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
79chiefs is offline  
post #5 of 8 Old 07-24-2013, 08:46 AM Thread Starter
cherosport
Registered User
2000 XJ Cherokee 
 
Join Date: Jul 2013
Location: Beloeil
Posts: 5
Ok, than you suppose that it could be the problem ?

I read somewhere that Alternator ground connection can be a problem ? What you think about ? And how can I look at this.
cherosport is offline  
post #6 of 8 Old 07-24-2013, 08:52 AM
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington
Posts: 994
Cheak all grounds, and wire for corrosion. Have the battery and alternator tested it you feel they could be the issue.

99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
79chiefs is offline  
post #7 of 8 Old 07-24-2013, 09:26 AM Thread Starter
cherosport
Registered User
2000 XJ Cherokee 
 
Join Date: Jul 2013
Location: Beloeil
Posts: 5
Ok I just start it and let it run on park. When temp gauge get 85 - 90 the motor shut off.

If it was a battery or alternator problem I will have problem to restart but I can always restart it without problem.

Does what I said sounds right ?
cherosport is offline  
post #8 of 8 Old 07-26-2013, 12:17 PM Thread Starter
cherosport
Registered User
2000 XJ Cherokee 
 
Join Date: Jul 2013
Location: Beloeil
Posts: 5
SOLVED - Fast and low cost repair

Condition:
  • Truck can always start when cold
  • Motor (want or simply cut off) when temps get normal truck temperature
  • Truck can always restart when motor cut off.
  • You canuse your tuck if you are enought fast to place it on neutral everytime you're at a stop sign or red light.

Ok,here's how to solve the problem describe above.

I goes to my favorite mechanic and they take 20 min to remove the throtle body, it was really dirty of Cabon. He completely clean it with air admission cleaner. Finaly he fix it on the motor. The problem was solved and my truc now idle at 500-600 and don't shut down every red light.

NB: Mechanic don't save on product

Cost: 39$

Last edited by cherosport; 07-26-2013 at 12:35 PM.
cherosport is offline  
Reply

Tags
4.0l , cherokee , low idle , shut off

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome