-   XJ Cherokee Technical Forum (
-   -   Interesting Throttle Problem... (

Lizardtheinsane 05-09-2013 10:28 AM

Interesting Throttle Problem...
I'm new here and almost at my wits end so I'm gonna lay this out for you all and see what you think. Sometime in late 2012, My 1998 Jeep Cherokee (XJ?) would sputter randomly. (And rarely.) It would do this for maybe 10 seconds then straighten out and run smooth. It would do this maybe once a month. (Or two.)

In March it did it one evening, then in the morning was still acting up so I took it to my mechanic. On the way there, it had another fit and the Check Engine light came on. Luckily, I made it. My mechanic couldn't get it to act up. It was throwing the P0122 code. (Throttle Position Sensor/Switch A Circuit Low Input)

When the were pulling it into the bay to deal with that, it started acting up and died. At that point it would no longer start and they could no longer communicate with the PCM... The PCM was dead... WTH! My mechanic said "I don't do computers man, you gotta take it to the dealer down the road." I had it towed to the dealer and they charged me $100 to confirm that the PCM was in fact dead. Said it'd be $960 plus tax to replace...

I laughed and had it towed back home. I ordered a remanufactured PCM off Ebay with a lifetime warranty for $180, flashed with my VIN# and Mileage. It showed up in a beat up box. (Gotta love UPS!) I contacted the company and ask to swap it out, they flashed another unit and sent it out to me with the understanding that I send back the other unit along with my Oringal dead PCM as my core.

I Undid the battery, installed the "original" replacement PCM, hooked the battery back up and the Jeep started right away. Check Engine Light was on. Plugged in a code reader, and it was throwing the ONE code... The same P0122 / TPS code. I undid the battery again, installed the 2ND PCM they sent me, hooked the battery back up and started the Jeep. Check Engine Light came on again. Plugged in the code reader and it said the same.... P0122 / TPS.

That's 3 PCM's throwing the same code... Good enough for me... My dad and I took Autozone's instructions for testing the TPS wiring and all seemed to test OK. When we tested the TPS middle prong to battery and adjusted the throttle, the voltage is supposed to climb smoothly but it would not change until a certain point then it would jump from like .5 to maybe 3.0. According to all I've watched and read, this is indicative of a bad TPS... I wanted to test the middle wire from the TPS connector to the PCM but have NO idea which pin on which PCM plug that would even be...

SO, I just changed the throttle position sensor the other night and actually drove it down the street several times. I even went and put a little gas in it. I thought all was well until I started climbing a steep hill on the way home. It started skipping, jerking, etc. By the time I pulled in my driveway it was doing the old sputter, rough idle thing. I turned it off, fearing this other PCM might get popped too. I pulled the TPS and exchanged it for a new one. (Who knows, maybe it was a bad TPS I bought.) I'm going to install TPS #2 tonight but don't feel very confident this will solve it...

Can a TPS burn up a PCM or do you guys think I'm looking at a wiring issue? (Cringes at the mere thought...) 3 PCM's saying it's the TPS but TPS didn't do it. I'll update tonight or tomorrow when I get TPS #2 installed but again, I dont feel confident that's the problem.

buildin1XJ 05-09-2013 10:56 AM

Where did you purchase Your TPS from? Cheap lifetime warranty sensors from A Zone Advance etc many times fail right out of the box or have very short life. You did say that TPS 1 fixed the problem for a short time so I would suspect that it failed. There are many posts here about aftermarket cheap sensors failing. I myself when replacing engine mgt. sensors buy from the dealer or NAPPAs best quality sensors. Yes NAPPA has a cheap part and a quality part.

Lizardtheinsane 05-09-2013 11:32 AM

Interesting. I did get the TPS at Autozone... Yep, Lifetime warranty... I have some friends that run a NAPA store about 35 minutes away. If this Autozone TPS replacement doesn't do the trick. Maybe I need to get it at NAPA... If it WE'RE the wiring, wouldn't that throw a different code? Like for the Wiring Harness? I hate sounding like an idiot. Lol. I can work on a car but when it comes to wiring, and the whole computer thing. That's something I'm working on here...

buildin1XJ 05-09-2013 11:49 AM

Your TPS testing shows a bad TPS because it jumped instead of making a clean sweep not to mention the cheap Idiot Zone TPS fixed it for a short time. BTW I see no way that a bad TPS will harm you PCM.

Lizardtheinsane 05-09-2013 07:45 PM

Well, I installed TPS #2 from Autozone and the problem is still there... I'm about to light this thing on fire. Very frustrated... At first I turned in on halfway but didn't start the engine...
The check engine light came on, went off, then came on for good again. Turned the key all the way to start it and nothing happened. I mean nothing. Didn't start. Dash lights gone as well. I opened the door and the interior light wasn't even on... I disconnected the battery, waited 30 minutes (Supposedly to reset the PCM.) Reconnected the battery, got in, turned it all the way on this time and it started but check engine light is still on and it's idling like the whole thing is about to explode. :(

CJ7-Tim 05-10-2013 11:21 AM

Buy a genuine Jeep TPS.

What Check Engeine Light code numbers were downloaded ? If the CEL is ON, your Jeep is trying to tell you what is wrong.

The starting symptoms and the dome lamp issues point to a bad battery, or wiring issues such as corroded cables and/or connection points.

Lizardtheinsane 05-10-2013 09:40 PM

Interesting turn of events... I hooked up the code reader tonight expecting to see the P0122 code but instead got the P0123 code... I ran some searches and came across some interesting talk of the clockspring. I'd forgotten all about it, thinking it irrelevant but just before my intermittent sputtering started, my "Airbag" light came on. It goes off momentarily sometimes but pretty much stays on. About a month before having to take it to the mechanic, my horn started honking on it's own one night. This is weird because my horn doesn't work when you press it... Anyway, I pulled the horn relay that night and have never replaced it. Regardless, here's a Jeep Forums thread thread I came across on Google...

These clockspring symptoms are all too familiar here... Anyone else had to deal with this issue?

CJ7-Tim 05-11-2013 07:24 AM

It does happen now and then.


A late model Jeep with a 2.5 or 4.0 liter engine and the AW4 transmission comes in with the “MIL” Check Engine Light illuminated and a complaint of late shifts. A scan reveals a code P0123, “TPS Voltage High”, is stored. The scan tools data list indicates that the TPS signal wire voltage is at 5.0 volts at closed throttle, and then ranges up to 11.5 volts. A back probe of the TPS signal wire (usually is an Orange/Dk Blue wire), shows 5.7 volts at closed throttle, with a similar rise in voltage as the throttle is opened. A check of the TPS 5 volt supply and ground circuit prove that both of these circuits are good.

A check of the TPS signal wire with the TPS disconnected shows the same 5.7 volts. Inspection of the wiring between the TPS and the PCM and TCM shows no faults. A replacement TPS does not cure the problem, neither does replacement of the PCM or TCM.


The Switch Sense circuit in the Clock spring in the steering wheel hub has shorted to battery voltage from the horn button circuit. When the Switch Sense Circuit shorts to the 12 volt HORN circuit the TPS signal voltage is driven high and remains there as shown. This is because the 5 volt reference voltage used by the Cruise Control “Switch Sense” circuit and the TPS are shared inside the PCM.


Unplugging a faulty Clock Spring should return the TPS voltage to its’ normal readings. Or, you can remove the Horn Relay in your junction block - this will remove the 12 VDC supply to the clock spring. Once the short circuit is temporarily disconnected, you should be able to reset the trouble code, and confirm you diagnosis of a faulty clock spring.


Replace the Clock spring assembly. Once the Clock spring has been replaced be sure to check the sensor 5volt reference voltage at the PCM to insure that circuit has not been damaged by the short to power. Also check the TPS signal range to insure the TPS has not been damaged.

Lizardtheinsane 05-11-2013 12:25 PM


Originally Posted by CJ7-Tim (Post 15419077)
Unplugging a faulty Clock Spring should return the TPS voltage to its’ normal readings. Or, you can remove the Horn Relay in your junction block - this will remove the 12 VDC supply to the clock spring. Once the short circuit is temporarily disconnected, you should be able to reset the trouble code, and confirm you diagnosis of a faulty clock spring.

Well I was gonna try to unplug the Clockspring today but don't know if it'll help. Before all this started, when my horn (That didn't work) started randomly honking I pulled that horn relay and haven't put another in there. According to this, when my TPS trouble started the clockspring wasn't even getting any juice. But my Airbag light is still on even now... (Scratches head.)

I'm also trying to figure out how to check the sensor 5volt reference voltage at the PCM...

Lizardtheinsane 05-14-2013 09:12 AM

Just to update and (Knock on wood.) close this out... I got to the clock spring and unplugged it last night. I hooked the battery back up, turned the key halfway and the check engine went off... And stayed off... I plugged in the code reader and got NO codes. Started her up and she runs like a top. Or at least like she did... It's the craziest thing, this clock spring business. messing with the TPS...

PLEASE NOTE: Above it says you can simply unplug the horn relay to rob the clock spring of it's power. My horn relay has been pulled for months (From the inside - passenger side junction box.) and this still happened. Only when I got in there and unplugged the 2 plugs going into the back of the clock spring did this problem go away... Literally *poof!* In my case I luckily did NOT have to pull the steering wheel. :)

The time now is 11:40 AM.

Powered by vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.