Instrumentation Malfunction and IOD Fuse problem -

LinkBack Thread Tools
post #1 of 1 Old 06-22-2013, 02:18 PM Thread Starter
Registered User
2001 XJ Cherokee 
Join Date: Nov 2007
Location: Plainfield
Posts: 66
Instrumentation Malfunction and IOD Fuse problem

So I found a thread regarding fixing the dead gauges in my 2001 Cherokee. But I also have an issue with the IOD fuse blowing while trying to replace. Do you think this will go away after taking the gauge cluster out and cleaning? Or is there some other problem here. The engine grounds look good. A bit dirty from valve cover leak. I'll take those off and clean them also. None of the dead gauge threads include the IOD problem. Any insight appreciated.

KennyKaraoke is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome