I need experts help!! Oil pressure guage at zero always not sending unit!! Help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > I need experts help!! Oil pressure guage at zero always not sending unit!! Help

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Savvy FREE SHIPPING!Year End Clearance Sale! Save 20%

Reply
Unread 05-29-2012, 02:54 PM   #1
steelbluexj
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2010
Location: VA
Posts: 8
I need experts help!! Oil pressure guage at zero always not sending unit!! Help

Hi to all, I have a 98 jeep xj 4.0l auto. My issue is that after I start the oil pressure guage never reads!! It will bump a little but not up to the first reading. I have tried the following: 5 different oil pressure sending units including 2 mopar ones, a jumper wire to trick the guage, a new pcm, swapped clusters, bypassed the splice block and ccd bus(which is now hooked backed up to the original way)... Seriously people I need help with this issue, Ive had three different mechanics and a ton of money spent to try and fix this!! I am only in desperate need to fix because I have found an 01 yellow sport for a great deal!! Please anybody with any input would be greatly appreciated

steelbluexj is offline   Reply With Quote Quick reply to this message
Unread 05-29-2012, 04:50 PM   #2
cactus_jack
Registered User
1998 XJ Cherokee 
 
Join Date: Jul 2009
Location: Morehead, Kentucky
Posts: 627
You could have a weak connection somewhere. Clean all of your grounds thoroughly. Trace the harness wire from your sending unit clear to the computer and check it for cracks, bad grounds, etc. May not be the problem but it cant hurt to try. Good luck and let us know what you find.
__________________
CACTUS_JACK
98 XJ Sport Budget Build
cactus_jack is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 09:15 AM   #3
steelbluexj
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2010
Location: VA
Posts: 8
I've checked all the wiring, I had a mechanic hook up a computer that sends a pulse through the wire to make sure it's good from one end to the other all the way to the cluster. We are still completely stumped with this issue
steelbluexj is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 09:17 AM   #4
Saudade
Registered User
1988 XJ Cherokee 
 
Join Date: Jun 2008
Location: SoCal
Posts: 1,381
Did you use a mechanical gauge to verify the oil pressure?
Saudade is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 10:29 AM   #5
steelbluexj
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2010
Location: VA
Posts: 8
Yes I installed one from advance and my oil pressure is great! It's about 45-50 at cold start so it's good.
steelbluexj is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 06:06 PM   #6
GrnJeep
Registered User
1999 XJ Cherokee 
 
Join Date: Sep 2010
Location: Tuscumbia, AL
Posts: 180
Did you try the key trick to get the guages to run through the test cycle? I cant remember off hand what the key on off count is but maybe someone on here will remember.
GrnJeep is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 06:10 PM   #7
steelbluexj
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2010
Location: VA
Posts: 8
Yes many times I have tried the guage sweep test. They all work and like I said I even swapped clusters. Still no reading from the guage
steelbluexj is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 08:43 PM   #8
ggjeep
Registered User
1996 XJ Cherokee 
 
Join Date: Nov 2006
Location: North Georgia U.S.A.
Posts: 222
Quote:
Originally Posted by steelbluexj View Post
Yes I installed one from advance and my oil pressure is great! It's about 45-50 at cold start so it's good.
Leave it hooked up and don't sweat it, you've got good pressure.
__________________
1996 XJ Sport 4.0/AW4
ggjeep is offline   Reply With Quote Quick reply to this message
Unread 05-30-2012, 08:59 PM   #9
steelbluexj
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2010
Location: VA
Posts: 8
I have for the time being, but like I said I'm trying to sell it and it will kill any interested parties because 0 oil pressure and check guages light stays on.
steelbluexj is offline   Reply With Quote Quick reply to this message
Reply

Tags
help please

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.