help please - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 07-19-2017, 04:33 PM Thread Starter
antman420XJ
Registered User
1990 XJ Cherokee 
 
Join Date: Oct 2016
Location: Dallas
Posts: 5
Garage
help please

I have a 1990 Cherokee Laredo 4.0l and trying to figure out a problem.. My biggest problem is I'm no mechanic and not loaded with money lol.. My jeep all of a sudden died on me while driving. I was able to put in neutral and starts right back up only to have it die on me 20yards later.. Did a little research and I replaced my CPS sensor cause that seem to match my problem. It ran ok for about an half hour and right back to the same thing.. I have also replaced my o2 and knock sensor any other suggestions with out having a repair shop charge my an arm and a leg to diagnose the problem.. Thanks in advance

antman420XJ is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 07-19-2017, 05:16 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,570
You are wasting money on parts which have no effect on it dying. Namely the O2 sensor and knock sensor.

TEST your new CPS.

Directions here:

http://cruiser54.com/?p=50

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #3 of 11 Old 07-20-2017, 09:00 AM Thread Starter
antman420XJ
Registered User
1990 XJ Cherokee 
 
Join Date: Oct 2016
Location: Dallas
Posts: 5
Garage
The knock sensor and o2 sensor were replace when i replace my cracked exhaust manifold simply cause the heat from the busted exhaust manifold melted the wiring.. Thanks for the link and could it possible be fuel pump related?
antman420XJ is offline  
 
post #4 of 11 Old 07-20-2017, 09:02 AM Thread Starter
antman420XJ
Registered User
1990 XJ Cherokee 
 
Join Date: Oct 2016
Location: Dallas
Posts: 5
Garage
TY again for link.. tested the new CPS and only got .2 reading so hopefully the next one will do the trick.. Is there any part site you would recommend?

Last edited by antman420XJ; 07-20-2017 at 12:15 PM.
antman420XJ is offline  
post #5 of 11 Old 07-20-2017, 01:59 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,570
Quote:
Originally Posted by antman420XJ View Post
TY again for link.. tested the new CPS and only got .2 reading so hopefully the next one will do the trick.. Is there any part site you would recommend?
Be sure to modify it per the link.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #6 of 11 Old 07-23-2017, 12:18 AM
KF4SQB
Registered User
1994 XJ Cherokee 
 
Join Date: Nov 2009
Location: SouthWest Georgia
Posts: 636
Quote:
Originally Posted by antman420XJ View Post
Is there any part site you would recommend?
Anywhere you can get an OEM Mopar sensor. Aftermarket versions are known to fail, if they ever work properly.

4-wheeling: because football, basketball, baseball, and golf only require one ball!


Confidence: The feeling you get just before you fully understand the situation!
KF4SQB is offline  
post #7 of 11 Old 07-24-2017, 08:24 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,570
I don't know anymore. I part out Jeeps so I have a constant supply.

Try doing the drill trick on the one you have.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #8 of 11 Old 07-26-2017, 03:44 PM Thread Starter
antman420XJ
Registered User
1990 XJ Cherokee 
 
Join Date: Oct 2016
Location: Dallas
Posts: 5
Garage
I did the drill and went to a 3/8 hole and still no good.. Went ahead and changed out the map cause already knew that was not working properly.. Running real rich and very poor gas milage.. After the MAP ran with idle real low but did responded well for about 30min and right back to where I started.. Cranks up but won't stay running.. Going to try to find a mopar CPS but not having any luck

Last edited by antman420XJ; 07-26-2017 at 04:25 PM.
antman420XJ is offline  
post #9 of 11 Old 07-26-2017, 03:45 PM Thread Starter
antman420XJ
Registered User
1990 XJ Cherokee 
 
Join Date: Oct 2016
Location: Dallas
Posts: 5
Garage
Cruier54 Do you have a used CPS up for sale?
antman420XJ is offline  
post #10 of 11 Old 07-26-2017, 05:33 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,570
Quote:
Originally Posted by antman420XJ View Post
Cruier54 Do you have a used CPS up for sale?
I don't think it's the cPS. Wouldn't run at all. Super rich is MAP circuit and vacuum generally.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #11 of 11 Old 07-26-2017, 07:17 PM
Nick05
Registered User
1994 XJ Cherokee 
 
Join Date: Jan 2013
Posts: 702
Quote:
Originally Posted by antman420XJ View Post
I did the drill and went to a 3/8 hole and still no good.. Went ahead and changed out the map cause already knew that was not working properly.. Running real rich and very poor gas milage.. After the MAP ran with idle real low but did responded well for about 30min and right back to where I started.. Cranks up but won't stay running.. Going to try to find a mopar CPS but not having any luck
Will it stay running if you give it a little skinny pedal? If so, try cleaning the iac(it's real easy) and throttle body. Might also check fuel pressure/replace filter.
Nick05 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome