HELP; 2000 cherokee wont fire - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > HELP; 2000 cherokee wont fire

JK Front Lower Adjustable Control Arms!QTP Low Profile Cutouts Now @ MarylandSpeed- Free ShippingOPTIC ARMOR WINDOWS all sale now !!!!!!!!

Reply
Unread 05-08-2010, 06:02 PM   #1
pwmach1
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2010
Location: Johnson
Posts: 23
HELP; 2000 cherokee wont fire

Hi guys
I am asking for help again. I have a 2000 Cherokee with a 4.0. I just did a motor swap. The original motor had a hole in the block so I bought a new reman. Took out the old motor on Monday. Switched everything over during the week and installed the new one yesterday. Finished the final hook up today. Now I cant get it to fire. It will crank but will not fire. Any help would be appreciated. Thanks

pwmach1 is offline   Reply With Quote
Unread 05-08-2010, 07:55 PM   #2
Fillergirl
Registered User
1988 XJ Cherokee 
 
Join Date: May 2010
Location: Canada
Posts: 87
Electrical? XD
Fillergirl is offline   Reply With Quote
Unread 05-09-2010, 09:54 AM   #3
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,380
You've got some work to do.

Need to know whether it is missing spark, fuel, or both.

Once you know that, the suspect list gets a whole lot shorter.

Be sure that the crankshaft position sensor and associated wiring is all good.

Does the fuel pump come on and run for about 2 seconds when you turn the key to the "ON" position. That doesn't guarantee fuel is making it to the injectors but it is something to verify.

Did you try spraying a small amount of starting fluid into the intake? If it starts and runs momentarily, you have verified that you have a fuel delivery problem.
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline   Reply With Quote
Unread 05-09-2010, 10:12 AM   #4
pwmach1
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2010
Location: Johnson
Posts: 23
I have fuel . But no spark. All the wires are hooked up. I just dont know were to look next.
pwmach1 is offline   Reply With Quote
Unread 05-09-2010, 11:39 AM   #5
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,380
Quote:
Originally Posted by pwmach1 View Post
I have fuel . But no spark. All the wires are hooked up. I just dont know were to look next.
What do you mean by "I have fuel"?

Do you mean that you have fuel pressure at the schrader valve on the fuel rail or have you verified that fuel is getting TO the fuel injectors and that the injectors are firing (use of a noid light can be helpful here).

Just because the fuel pump runs doesn't mean you're getting fuel TO the injectors. The computer has to have certain input signals before it allows that to happen.

Do you smell gas? Are the spark plugs wet with gas when trying to start? If they are dry, try the starting fluid suggestion I made earlier.
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline   Reply With Quote
Unread 05-09-2010, 05:30 PM   #6
pwmach1
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2010
Location: Johnson
Posts: 23
I do smell fuel when the engine cranks and I have fuel at the rail. But I do not have spark.
pwmach1 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.