Help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Help

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 03-30-2013, 03:14 AM   #1
bbowling0039
Registered User
 
Join Date: Mar 2013
Posts: 7
Help

OK i have a 1996 jeep Cherokee Laredo and it has just died on me and its not firing. I was driving it down the interstate and every couple min it would miss then i would slow back down to around 55-60 and it wouldn't do it then i speed back up and it shut off it cranks and cranks but wont start i checked to see if it was firing and it wasn't, so i had it towed in. It already has a new distributor cap and rotor button, new plugs and plug wires. so when it wasn't firing the first thing that came to mind was the coil pack so put a new one on it and it fired right up. So i figured it was fixed next day on my way to work same thing happens again. WTF. So a buddy of mine a mechanic said the only thing else it could be would be the ignition control module so i put a new one on it and still nothing. What else would make it not fire. Could it be the crank sensor? That is the only thing i can think of. When i bought it, it had a little miss and i noticed the next morning that it has a rough cold start. It will crank fast then slow way down almost like it has a dead battery but it has a new one, but after its warmed up it will start right back up fast. Please any advise would be appreciated i cant figure this thing out im tired of buying random parts and nothing fixing it. Oh yea and there is no check engine light on either there was when i first got it i checked it and it was a cylinder 1 misfire but it went away on its on randomly. HELP....

bbowling0039 is offline   Reply With Quote Quick reply to this message
Unread 03-30-2013, 08:30 AM   #2
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 969
It could indeed be the CPS.
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.