Heat doesn't work, in the winter of course. HELP! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 11-28-2012, 02:48 PM Thread Starter
Grizzly944
Registered User
1999 XJ Cherokee 
 
Join Date: Aug 2010
Location: Central,CT
Posts: 59
Heat doesn't work, in the winter of course. HELP!

So my heat does not work, and neither does my A/C. I just replaced my radiator because it was leaking. My Accessory fan does not work anymore. I have a light colored smoke coming from my vents when the vehicle warms up, and when on the highway. Even with the A/C and heat are off. It smells pretty bad. I have read that it could be the heater core, but i've checked out the floor board and its not wet. So if anyone can recommend anything, without me removing the whole dash to fix the heater core that would be awesome! Thanks, and sorry for the paragraph.

Grizzly944 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-28-2012, 03:00 PM
jeepkid03
Winning
 
jeepkid03's Avatar
2000 XJ Cherokee 
 
Join Date: Sep 2008
Location: Storrs
Posts: 6,193
A good heater core flush (back and forth) makes a big difference. Lots of crap can build up in there. I used Prestone Radiator flush and it helped. Then a local vintage car guy suggested using Cascade dishwasher soap (the gel kind) and it really cleaned lots of stuff out of the heater core. My heat works much better.

I would try that to get any crap out of the core first. You may have a leak though. Also, does your accessory fan not work due to a bad relay, fan motor, or sensor?

The temp sensor might not be reading correctly which won't turn the fan on at the right temp.

Where in CT are you?
jeepkid03 is offline  
post #3 of 5 Old 11-28-2012, 03:40 PM
rayxjs
Registered User
 
Join Date: Aug 2012
Posts: 3
My 99 sport heats but don't use it because it smells like exsuoust , live in Pa turn it on for a few min then shut it off , just to take the chill out in the morning.any one heard of this.

Sent from my iPhone using JeepForum
rayxjs is offline  
post #4 of 5 Old 11-28-2012, 04:03 PM
AZ Jeff
Web Wheeler
2014 JK Wrangler 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona
Posts: 7,698
Quote:
Originally Posted by Grizzly944 View Post
So my heat does not work, and neither does my A/C. I just replaced my radiator because it was leaking. My Accessory fan does not work anymore. I have a light colored smoke coming from my vents when the vehicle warms up, and when on the highway. Even with the A/C and heat are off. It smells pretty bad. I have read that it could be the heater core, but i've checked out the floor board and its not wet. So if anyone can recommend anything, without me removing the whole dash to fix the heater core that would be awesome! Thanks, and sorry for the paragraph.
If the core is confirmed to be leaking, there is NO WAY to remove it without taking the dash apart to gain access to the heater box and then remove it to remove the core.

AZ-Jeff
I don't own an XJ any longer, but I still think they are the best of all the Jeep products ever made. My XJ was my favorite vehicle in my 50+ years of driving.
So...I stick around and give advice.
AZ Jeff is offline  
post #5 of 5 Old 11-29-2012, 06:54 AM Thread Starter
Grizzly944
Registered User
1999 XJ Cherokee 
 
Join Date: Aug 2010
Location: Central,CT
Posts: 59
Quote:
Originally Posted by jeepkid03 View Post
A good heater core flush (back and forth) makes a big difference. Lots of crap can build up in there. I used Prestone Radiator flush and it helped. Then a local vintage car guy suggested using Cascade dishwasher soap (the gel kind) and it really cleaned lots of stuff out of the heater core. My heat works much better.

I would try that to get any crap out of the core first. You may have a leak though. Also, does your accessory fan not work due to a bad relay, fan motor, or sensor?

The temp sensor might not be reading correctly which won't turn the fan on at the right temp.

Where in CT are you?
Thanks, i'll give that a try. And im far away from storrs haha, Plainville
Grizzly944 is offline  
Reply

Tags
a/c , heat , heater core

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome