Gauges and turn signals not working. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 06-13-2010, 03:35 PM Thread Starter
Showtime3492
Registered User
2000 XJ Cherokee 
 
Join Date: Jun 2010
Location: York
Posts: 961
Gauges and turn signals not working.

So i just bought a 98 XJ with 163 on the clock and a rust free good condition body. The guy i bought it off said the gauges and signals used to work once in a while but now they just totally stopped. Also have an airbag light on not sure if that makes any diff or helps. Hazard lights work though. Im goin to pick it up tomorrow so when i get it home im gonna start investigating what it could be but any ideas or if you have had the same problem please let me know what it was and the fix. Thanks!


Last edited by Showtime3492; 06-18-2010 at 03:00 PM.
Showtime3492 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Turn signals not working............ g26 XJ Cherokee Technical Forum 1 05-26-2009 09:37 PM
turn signals not working cardana24 XJ Cherokee Technical Forum 4 10-09-2006 10:56 AM
Turn signals stopped working Jenniegirl XJ Cherokee Technical Forum 3 03-02-2006 07:00 PM
99 turn signals not working 46CJ2A XJ Cherokee Technical Forum 4 01-10-2005 02:36 PM
turn signals and hazards not working. puckjer XJ Cherokee Technical Forum 2 11-15-2004 04:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome