Fuse keeps blowing out - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 06-11-2013, 02:16 PM Thread Starter
powpow
Registered User
 
Join Date: Jun 2013
Location: wenatchee
Posts: 1
Fuse keeps blowing out

So this 50amp fuse that powers my cooling fans keep going out in my 2005 4.7L. It sits right next to the hi and low relays. I put in a new stereo head unit a couple months ago if that might be doing something. What would you guys do? thanks

powpow is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-12-2013, 09:43 AM
foggybottombob
Registered User
1984 CJ7 
 
Join Date: May 2008
Location: Monument Colorado
Posts: 5,840
sounds like you have a grand cherokee. This is the XJ cherokee forum.
foggybottombob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome