Fuel pump relay issues. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Fuel pump relay issues.

Savvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHutIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-26-2012, 03:23 PM   #1
robert644
Registered User
1989 XJ Cherokee 
 
Join Date: Aug 2009
Location: Juneau, Alaska
Posts: 51
Fuel pump relay issues.

Hello,

Well, I am trying to make my poor 89 XJ get up and go, but it is one thing after another apparently. I replaced my leaky original injectors with nice Bosch 00280155746 ones, but then developed a leak at the rail/hose fitting. Of course no one knows what a fuel line quick disconnect kit is here in town.

After solving that, my fuel pump up and gave up. There is power to the relay, and I can jumper the connections and make the pump go, however nothing with the relay - except

When I initially turn the key, the pump fires up for about a second, then quits and stays off. If I bleed the system with the fuel pressure testing port, the pump does not kick in to maintain pressure, and I don't recall seeing anythihng about a pressure switch anywhere in the system anyhow.

Also, if I hotwire the switch, the vehicle still doesn't want to start.

The longer I own this car, the more I realize I can't give up on it, for all the time and effort put into the thing, and the specific knowledge about it! I hope this isn't a bad ECU though, and perhaps I need to just hotwire the thing as the ignition key switch gave out some time ago.

Thanks for your help and time.

robert644 is offline   Reply With Quote Quick reply to this message
Unread 03-26-2012, 04:28 PM   #2
robert644
Registered User
1989 XJ Cherokee 
 
Join Date: Aug 2009
Location: Juneau, Alaska
Posts: 51
So I read that when turning the key, there is an initial prime, after which the pump shuts off. Then it reactivates during cranking. Vehicle will still not start, and testing indicates voltage to the coil. I guess I will pull out my spark tester next!
robert644 is offline   Reply With Quote Quick reply to this message
Reply

Tags
fuel pump , relay , voltage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.