post #1 of Old 01-02-2013, 05:46 PM Thread Starter
CaptainPrinny
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2011
Location: Manchester
Posts: 3
Front end clicking a pulsing

Maybe I'm just slow, but I couldn't seem to fine my issue. It just started happening recently, but I'm getting a rough tapping feeling from the front end. It doesn't seem to matter whether I'm turning or going start, and it's most noticeable when breaking. You can feel it as soon as you touch the break you can actually feel t it best through the brake pedal. It only really happens when I hit the brake about 20mph, with and without 4wd engaged. Sounds like something's loose up there, but visually, I can't see any issues. I haven't taken anything apart yet because of my work schedule, and seeing how it's 10 degrees outside, I'm just looking for possible points to check make this move a little faster.

*I feels like a sharp shock on the brake pedal that seems to be speed based, but too harsh to be a hard spot on the rotor, and it doesn't matter how hard I press the brakes.

CaptainPrinny is offline  
Reply

Tags
brakes , front , thump , ticking


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome