Few electrical issues, need help before inspection - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Few electrical issues, need help before inspection

Jeep Wrangler Bushwacker Flat Fender Flare Sale at BaselinJeep Wrangler Complete Gear Upgrade Kits with Installs andIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-11-2013, 06:30 PM   #1
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
Few electrical issues, need help before inspection

1-Wipers only work on full speed
2-No turn signals-believe it is the relay and gonna go change it with a new; post your thoughts on this
3-No horn
4-not needed for inspection but also could use help---no dash lights at all
5- temp gauge does not work, how can i test it; cannot afford to get a new sensor right now just for it to not be the problem.

PLEASE HELP
88 Jeep Cherokee 4.0 Auto 4x4

__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 06-11-2013, 06:51 PM   #2
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
Changing the relays did not help, still no turn signals, and now hazards flash weird.
NO fuses blown.
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 06-12-2013, 11:13 AM   #3
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
Bump???
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 06-12-2013, 12:07 PM   #4
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
Took all fuses back out and put in at random, signals now work.
Now it is missing like crazy.
I NEED the horn for inspection.
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 06-12-2013, 07:57 PM   #5
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
Found the horn relay, i never thought it would be that hard, i read so many threads that none had ever found it, but i did, and it is bad, jumped the pins till it sounded the horn.
run out of gas, so that is the missing issue, i think my gas was stolen because i put 6 gallons in it, and it has just sat for 2 weeks while i get the paperwork done on it.
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 06-12-2013, 07:58 PM   #6
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
So 2;3;5 are solved
5- grounded out the gauge and it worked so i bought a sensor.
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 06-13-2013, 10:27 AM   #7
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 963
Forgot most important part
STILL NO BRAKES
I have bled many times, gravity, force bleed.
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.