Engine swap=no fire - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Engine swap=no fire

SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!FLASH SALE! Open thread to reveil the Newest Sale @ ROCKRIIntroducing MONSTALINERô UV Permanent DIY Roll On Bed Line

Reply
Unread 04-15-2015, 01:20 AM   #1
waffals
Registered User
2001 WJ 
 
Join Date: Nov 2012
Posts: 4
Engine swap=no fire

I've been reading through these forums for days and I'm lost still. So, here it goes. I did an engine swap on a 99 jeep Cherokee xj. I'm getting no fire from the plugs. I've been trying to weed it out by buying new parts daily and frankly, I'm stumped. New coil, cap and rotor, plugs, wires, stator. I'm getting no resistance on the crankshaft positioning sensor (after going through 2 of them). All grounds were Che led and cleaned, fuses are good. Everything that I can think of has been meter checked to make sure the proper voltage. IM NOW LOST! What else could it possibly be? The only thing I don't have, which I found in a threaded was the CAT 02 sensor is hooked to the ignition. Here in SC, don't really need a CAT, so pulled it. Can I bypass that? Thanks yall for any help I receive.

__________________
the jeep life chooses you, deal with it!
waffals is offline   Reply With Quote Quick reply to this message
Unread 04-15-2015, 05:40 AM   #2
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,457
You might try swapping the ASD relay with the Radiator Fan relay and see if that works.

When you have the ASD relay out check the pin cavities for the relay for corrosion or the pin cavities shoved down in the PDC.



PDC:

__________________
If we have data, letís look at data. If all we have are opinions, letís go with mine.
CCKen is offline   Reply With Quote Quick reply to this message
Unread 04-15-2015, 11:12 PM   #3
waffals
Registered User
2001 WJ 
 
Join Date: Nov 2012
Posts: 4
Got it thanks. Changed the CPS for the 3rd time and switched the relays around. Fired right up and purred like a kitten. Thank you for your help.
__________________
the jeep life chooses you, deal with it!
waffals is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.