did tune up and a fuel injector now runs rough please help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > did tune up and a fuel injector now runs rough please help

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-11-2012, 06:24 PM   #1
Hunt3r
Registered User
1991 XJ Cherokee 
 
Join Date: Feb 2012
Location: White Bear Lake, MN
Posts: 48
did tune up and a fuel injector now runs rough please help

its a 89 xj i did a tune up and changed one fuel injector and the o rings on the rest now it runs really rough it does not wanto accelerate and when you do get it to highway speed you can feel the engine shake like a tire thats out of balance. thank you for any help

Hunt3r is offline   Reply With Quote Quick reply to this message
Unread 03-11-2012, 06:25 PM   #2
DoctorTim
Registered User
1996 XJ Cherokee 
 
Join Date: Sep 2010
Location: Huntington Beach, CA
Posts: 2,462
make sure you plugged all of the connectors for the fuel injectors.
__________________
http://www.jeepforum.com/forum/f11/96-xj-build-hybrid-1311863/

96 XJ, geared, 8.8, 5", 33s, dash
DoctorTim is offline   Reply With Quote Quick reply to this message
Unread 03-11-2012, 06:27 PM   #3
habbyguy
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2010
Location: Mesa, AZ
Posts: 575
It would be really easy to get two of the injector plugs backward. You might try pulling the plugs off the injectors one at a time while the engine's running. If the idle doesn't get worse, you know that injector is part of the problem. If you pull off two plugs that don't make any difference, swap 'em and you're back on the road at 100%.
habbyguy is offline   Reply With Quote Quick reply to this message
Unread 03-11-2012, 06:52 PM   #4
Hunt3r
Registered User
1991 XJ Cherokee 
 
Join Date: Feb 2012
Location: White Bear Lake, MN
Posts: 48
Quote:
Originally Posted by habbyguy View Post
It would be really easy to get two of the injector plugs backward. You might try pulling the plugs off the injectors one at a time while the engine's running. If the idle doesn't get worse, you know that injector is part of the problem. If you pull off two plugs that don't make any difference, swap 'em and you're back on the road at 100%.
Thanks a lot it was two of the injector plugs switched around.
Hunt3r is offline   Reply With Quote Quick reply to this message
Reply

Tags
fuel injector , jeep , xj

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.