CPS (crankshaft position sensor) - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > CPS (crankshaft position sensor)

Bill Baird Motorsports DIY parts - NalinMFG.comFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-15-2002, 06:10 PM   #1
LOCKED UP
Senior Web Wheeler
 
LOCKED UP's Avatar
1998 XJ Cherokee 
 
Join Date: Jun 2002
Location: Close to Austin, TX
Posts: 3,878
CPS (crankshaft position sensor)

I'm just curious....

How many people have had this thing break and on what model year? What is the "newest" year you have heard of that had one fail?

Wondering if I should be worried about this in my 00'

__________________
... an no sidewindin' bushwackin', hornswagglin' cracker croaker is gonna rouin me bishen cutter.

98 XJ
LOCKED UP is offline   Reply With Quote
Unread 08-16-2002, 07:10 AM   #2
BadXJ
Registered User
 
Join Date: Oct 2001
Location: Fenton - - Michigan
Posts: 65
I have an 89 XJ and I carrie 3 with me all the time... I hope you dont have the problems older XJ had... I havent had to replace one in about 2 years now.... I think your should be fine.. but you may want to carry one with you...
__________________
89 XJ black 2 door -6" Tomken suspension lift, 33X12.5 Mud Kings, 4:56 RPs, Dana 35 w/ Detroit locker, Dana 30 front w/ Detroit locker, transfer case tailshaft eliminator, custom off-road driveshafts, AW4 trans w/ cooler, Tomken front and rear bumper SEE PIC SEE PIC @
http://www.imagestation.com/picture/sraid23/p4f2d1299a2eef160dc98d1b232d4bb6a/fda105c4.jpg
WIFE:
98 ZJ Limited, Loaded RED/BLACK
BadXJ is offline   Reply With Quote
Unread 08-16-2002, 07:33 AM   #3
bassicrob
Registered User
 
Join Date: Aug 2002
Location: Brooklyn, NY
Posts: 398
I have a '93 with about 76k miles and I had to replace mine 2 weeks after I was in a rollover. However, I am still getting the 11 code when I run the "check Engine Light" method diagnosis. Any clue? Last 50 cycles I presume or maybe still more probs?

Last edited by bassicrob; 08-16-2002 at 07:43 AM..
bassicrob is offline   Reply With Quote
Unread 08-16-2002, 07:40 AM   #4
williak
Registered User
 
Join Date: Aug 2002
Posts: 157
On both my 87 (140,000)and 88 (120,000)XJ's, the CPS failed and I never noticed. They both ran just as well on the distributor pick up. Never had an engine light, nothing. Found out they had failed during my regular check ups.
williak is offline   Reply With Quote
Unread 08-16-2002, 12:41 PM   #5
jpcomanche
Registered User
 
Join Date: Apr 2002
Location: Twin Cities, MN
Posts: 17
Quote:
Originally posted by williak
On both my 87 (140,000)and 88 (120,000)XJ's, the CPS failed and I never noticed. They both ran just as well on the distributor pick up. Never had an engine light, nothing. Found out they had failed during my regular check ups.
If your XJ's still ran, the CPS didn't fail. They might have been going bad, but they hadn't completely failed. If you don't believe me, go unplug your CPS and try to start your XJ. It will not run.

The CPS went out on my 90 MJ about a year and a half ago with about 90K miles.
__________________
1987 Wrangler
1990 Comanche Eliminator
2003 Wrangler Rubicon
jpcomanche is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.