coolant overflowing........... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 10-20-2002, 08:32 AM Thread Starter
jerryhipp
Registered User
 
jerryhipp's Avatar
 
Join Date: Oct 2002
Location: worcester, ma.
Posts: 54
Red face coolant overflowing...........

i've got a 88 cherokee and yesterday i shut it off and when i came back there was coolant all over the street. so i thought i overheated and didn't realize it. so i checked the gauge. not overheating. so i filled it back up and drove around for about an hour with no problems. temp. stayed around 210. shut it off and it started to pour out again all over the street. so i do know two things 1) it's not overheating. 2) it only overflows when it is shut down. i was thinking maybe head gasket, maybe sucking in air and creating a build up? but my friend says he thinks it's my coolant resevior cap seal. so first i'm going to buy a cap because it's cheaper and it can't hurt to try. but i would appreciate any help or advice from anyone.

thanx jerry

p.s. i checked all the hoses for a blockage. nope. and the overflow is coming out of the large hose at the bottom of the radiator, not from the overflow tank.

jerryhipp is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-20-2002, 09:15 PM
UglySkunk
Registered User
 
UglySkunk's Avatar
 
Join Date: Jun 2002
Location: Ft. Myers, Fl.
Posts: 165
my YJ did the same thing bout 6 months ago and it was the water pump

91 YJ currently rebuilding

my jeep can fly can yours

if you don't know about cages or spiked tang sit down and shutup
UglySkunk is offline  
post #3 of 4 Old 10-24-2002, 10:56 PM Thread Starter
jerryhipp
Registered User
 
jerryhipp's Avatar
 
Join Date: Oct 2002
Location: worcester, ma.
Posts: 54
thank you ugly skunk. that's exactly what it was. i changed it and the thermostat and it's running great. great advice, i apprieciate it.
jerryhipp is offline  
post #4 of 4 Old 10-25-2002, 10:01 AM
Apeman
Registered User
 
Join Date: Oct 2002
Location: Calgary,AB,Canada
Posts: 210
Mine did the same thing and after swapping the fan clutch still did it...it turns ou thtere was still air in the system and was adding unneeded pressure. When the system would "burp" the air out, it would also send coolant out with it...make sure you have no air in the system. It may save you $$ on a water pump.

99XJ - Lifted and whatnot..oh, and its white.
Apeman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
What Could Cause Coolant in Oil? Hardt114 XJ Cherokee Technical Forum 18 08-12-2009 05:55 PM
DO you run 50/50 coolant in the 4.0 inline 6 or just coolant Npfiremedic107 XJ Cherokee Technical Forum 11 07-14-2009 03:59 PM
coolant leak but cannot find lost coolant Jhatke XJ Cherokee Technical Forum 12 03-21-2009 06:54 PM
engine coolant overflowing m_w_m XJ Cherokee Technical Forum 6 08-04-2005 05:19 PM
overflowing expansion tank rokclimbertx XJ Cherokee Technical Forum 5 09-08-2004 08:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome