cherokee cranks over but wont start please help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > cherokee cranks over but wont start please help

The Original 3/8" Ruffstuff Diff Cover!Safety Thimble FairleadsEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 03-29-2009, 04:27 PM   #1
amazingman
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2008
Location: windsor
Posts: 25
cherokee cranks over but wont start please help

I have a 1992 jeep Cherokee limited 4.0 auto.
My jeep will crank over but it wont start.
It has a new coil pack newer plugs.
Fuel pump runs 1 psi more than it should i don't think that effects anything.
It has a brand new crank sensor.
Newer 136 amp alternator.
newer distributor .
1 yr old fuel filter .
i have also been putting 94 octane fuel from shell so it is not bad gas

The check engine light does come on once in a while and it says that my relays for the ac and cruise control need to be replaced that should not affect anything ??????

It is getting spark and it getting fuel but it is not running.

Now what it does from time to time it runs perfectly fine no problem starting or running for a little bit. Then as i am driving and the engine warms up it tries to stall between 1 & 2 thousand rpm and also at about 3500 rpm and also it runs at 1000 rpm idling usually when it is not acting up it is about 800 rpm. These problems usually seem to happen on warm days or when the engine gets warm. usually when it is cold it runs better at the beginning it might want to stall but then after you drive it a bit it is fine and doesn't do any thing. And when it is warm and it does start it runs really ruff and the exhaust smells like gas . I am stumped

The only things i can think of it being is the map sensor ,cps that is in the distributor or computer is going out once in a while????????????????

amazingman is offline   Reply With Quote Quick reply to this message
Unread 03-29-2009, 04:38 PM   #2
xjfever
Web Wheeler
 
xjfever's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2008
Location: north Ga.
Posts: 14,214
It could be thermal failure of the cam position sensor, I would test the throttle position sensor, and remove and clean the Idle air control and clean the throttle body also while your in there. If you have fuel and spark and it wont run then timing is the only other thing I could think of and the cam position sensor tells the injectors when to fire.
__________________
  1. '95 XJ country edition, 4" coils/3/4" spacers, HD leafs with extra main added in, Ironman adjustable control arms, rough country shackles, aussie locker, JK rubicon shocks, 35" mudder's, soft 8's, cobra cb
  2. Sold'99 WJ limited, 4.7L, 3" IRO lift. Bilstein shocks, JK rubicon wheels, 255/70/17's, carolina driveshaft, IRO adjustable control arms, IRO adjustable A-arm
  3. Sold '00 TJ, 4" lift, rusty's adjustable control arms, skyjacker shocks, rock krawler adj. trac-bar,rugged ridge SYE and RE driveshaft, soft 8's, 35" mud king xt's,XJ HP D30 w/aussie locker, 4:88 yukon gears, hella 500's, rock crusher diff covers
4. 04 Dodge ram 1500 quadcab, yes, it has a hemi.
5. '08 BMW X3, Mods in progress.
xjfever is offline   Reply With Quote Quick reply to this message
Unread 03-29-2009, 07:30 PM   #3
paulmatyn
Senior Member
 
paulmatyn's Avatar
1992 XJ Cherokee 
 
Join Date: Nov 2006
Location: Carlsbad, CA
Posts: 969
check to make sure that the distributer is turning as it is cranked. the gear on my distributer is all chewed up, and wouldnt spin.
__________________
Quote:
Originally Posted by Beefstew View Post
brain guts all over the windshield!!!!!!!!!!!!!!!!
Quote:
Originally Posted by WillysEdition04 View Post
After reading 7-8 of your posts I've come to the conclusion that you may be mentally retarded, which is why I won't ask what "brain guts" are.
Quote:
Originally Posted by Duck Dodgers View Post
I'd rather take the chance and belive in God than take the chance and not.
Cuz ya got nothing to lose by believing, but ya sure might if ya don't.
White Jeep Club Member-2027
paulmatyn is offline   Reply With Quote Quick reply to this message
Unread 03-29-2009, 07:56 PM   #4
mjjeeper
Registered User
1988 MJ Comanche 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 188
Fusible link.
mjjeeper is offline   Reply With Quote Quick reply to this message
Unread 03-31-2009, 02:20 PM   #5
amazingman
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2008
Location: windsor
Posts: 25
just changed the cam positoning sensor still runs like crap could it be the computer or a relay ??
amazingman is offline   Reply With Quote Quick reply to this message
Unread 03-31-2009, 02:49 PM   #6
vtine523
Registered User
1992 XJ Cherokee 
 
Join Date: Dec 2008
Location: Chesterfield, VA
Posts: 142
i was told when an engine doesn't run its either "fuel or fire"
__________________
** http://southsidejeepers.freeforums.org/ ** http://southsidejeepers.wetpaint.com/ **
vtine523 is offline   Reply With Quote Quick reply to this message
Unread 03-31-2009, 02:52 PM   #7
Nate97xj
Registered User
1997 XJ Cherokee 
 
Join Date: Nov 2008
Location: Seattle, Wa
Posts: 185
Crank position sensor, Throttle position sensor, Neutral Safety switch, bad fuel pump, idle air control valve. It could be many things...

I would also check the ignition control module, they usually don't come with a new distributor. These tend to fail when the engine gets hot, which would explain the fact that it runs for a while, then when it gets hot, it dies... Those can be tested too, if you have a ICM tester.
__________________
Green Jeep Club member #242

Last edited by Nate97xj; 03-31-2009 at 03:07 PM..
Nate97xj is offline   Reply With Quote Quick reply to this message
Unread 03-31-2009, 10:40 PM   #8
amazingman
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2008
Location: windsor
Posts: 25
i do not think that year came with a icu and it does have fuel and sparkand the fuel pump gives off 1 more psi than it should i still do not know what it is
amazingman is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.